[Koha-bugs] [Bug 3215] It would be nice if "Add to Cart" changed to "Remove from Cart"

bugzilla-daemon at bugs.koha-community.org bugzilla-daemon at bugs.koha-community.org
Mon Feb 6 17:06:36 CET 2012


http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=3215

Ian Walls <koha.sekjal at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |koha.sekjal at gmail.com

--- Comment #5 from Ian Walls <koha.sekjal at gmail.com> 2012-02-06 16:06:36 UTC ---
Given that Perl 5.10 is now the minimum version for Koha, it may prove more
efficient to use ~~ than grep.  For example:

if ( grep {$_ eq $biblionumber} @cart_list) {
   $this_item->{'incart'} = 1;
}

Becomes

if ( $biblionumber ~~ @cart_list) {
   $this_item->{'incart'} = 1;
}

Template level changes look good, and code is clean.  Just wanted to bring this
up to see if anyone had more information or an opinion on the matter before I
push through QA

-- 
Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the Koha-bugs mailing list