From bugzilla-daemon@bugs.koha-community.org Fri Oct 22 11:08:58 2021
From: bugzilla-daemon@bugs.koha-community.org
To: koha-bugs@lists.koha-community.org
Subject: [Koha-bugs] [Bug 11175] Show the parent record's component parts in
the detailed views
Date: Fri, 22 Oct 2021 09:08:56 +0000
Message-ID:
In-Reply-To:
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="===============5312692496753482145=="
--===============5312692496753482145==
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: quoted-printable
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=3D11175
--- Comment #425 from Jonathan Druart ---
Some patches have been squashed for readability.
(In reply to Marcel de Rooy from comment #390)
> 14 files changed, 322 insertions(+), 55 deletions(-)
>=20
> $showcomp variable naming; show_components better
Too late, too complicated or we add a separate commit for that. Not a big deal
IMO.
> Changes XSLTParse4Display; no tests. (Yes, there is no, but there should be=
.)
Still missing, I will try and provide some a bit later today.
> Code block if ($xslsyspref =3D~ m/Details/) {
> We are fetching components while we may not use them.
> Have the impression that the if inside the block should be incorporated into
> the main condition.
Done and squashed with the first patch.
> installer/data/mysql/atomicupdate/bug_11175.perl
> Needs to be converted to new style
I will do it when pushing it.
> +('ShowComponentRecords', 'nowhere', 'nowhere|staff|opac|both','In which
> record detail pages to show list of the component records, as linked via
> 773','Choice'),
> Should nowhere just be empty?
empty or 'nowhere' is fine.
(In reply to Marcel de Rooy from comment #391)
> What about indentation?
Done and squashed.
(In reply to Marcel de Rooy from comment #392)
> koha-tmpl/intranet-tmpl/prog/en/xslt/MARC21slimUtils.xsl
> koha-tmpl/opac-tmpl/bootstrap/css/src/opac.scss
>=20
> Seems you only remove 2 newlines, please remove these changes.
Done, squashed.
> + [% IF defaulttab =3D=3D 'components' %]
> +
> + [% ELSE %]
> +
> + [% END %]
> + Components ([% (
> ComponentParts.size ) %])
> +
>=20
> Indentation.
Done, squashed.
> diff --git a/koha-tmpl/opac-tmpl/bootstrap/en/xslt/MARC21slimUtils.xsl
> b/koha-tmpl/opac-tmpl/bootstrap/en/xslt/MARC21slimUtils.xsl
> index 105da508c7..2df0e1b3b4 100644
> --- a/koha-tmpl/opac-tmpl/bootstrap/en/xslt/MARC21slimUtils.xsl
> +++ b/koha-tmpl/opac-tmpl/bootstrap/en/xslt/MARC21slimUtils.xsl
> @@ -541,7 +541,6 @@
>
>
>
> -
>
>=20
>