[Bug 32051] New: Rename Library homepage link to Contact for single library
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Bug ID: 32051 Summary: Rename Library homepage link to Contact for single library Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: OPAC Assignee: oleonard@myacpl.org Reporter: m.de.rooy@rijksmuseum.nl QA Contact: testopia@bugs.koha-community.org We are wondering if it would be better/clearer to use a Contact link for a single library. If you list multiple libraries, we should stick to Libraries of course. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |caroline.cyr-la-rose@inlibr | |o.com See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=31817 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 --- Comment #1 from Owen Leonard <oleonard@myacpl.org> --- I think it's a good idea. "Libraries" is inaccurate and "Library" seems weird. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff Patch complexity|--- |Small patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 --- Comment #2 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 178385 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=178385&action=edit Bug 32051: Rename Library to Contact for one public library Note: I am using $rs in the script to prevent searching branches again unneeded. And pass public_count to opac-library.tt to prevent another call of Branches.all (for bread crumbs), like masthead already does btw. Test plan: [1] Have two (or more) public libraries. Verify that you see Libraries on the OPAC home page and that when clicking Libraries, you first have the library list. Are the bread crumbs as expected? Click a library on that list. Do you get its details? Are the bread crumbs as expected? [2] Now have only one public library. Verify that you see Contact on the home page. And that when clicking Contact you go directly to the library details without the intermediate library list. Are the bread crumbs still as expected (with Contact instead of Libraries)? Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|oleonard@myacpl.org |m.de.rooy@rijksmuseum.nl -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #178385|0 |1 is obsolete| | --- Comment #3 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 178403 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=178403&action=edit Bug 32051: Rename Library to Contact for one public library Note: I am using $rs in the script to prevent searching branches again unneeded. And pass public_count to opac-library.tt to prevent another call of Branches.all (for bread crumbs), like masthead already does btw. Test plan: [1] Have two (or more) public libraries. Verify that you see Libraries on the OPAC home page and that when clicking Libraries, you first have the library list. Are the bread crumbs as expected? Click a library on that list. Do you get its details? Are the bread crumbs as expected? [2] Now have only one public library. Verify that you see Contact on the home page. And that when clicking Contact you go directly to the library details without the intermediate library list. Are the bread crumbs still as expected (with Contact instead of Libraries)? Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> Signed-off-by: Owen Leonard <oleonard@myacpl.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 --- Comment #4 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 178404 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=178404&action=edit Bug 32051: (follow-up) Make the same change to page title Signed-off-by: Owen Leonard <oleonard@myacpl.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 --- Comment #5 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to Owen Leonard from comment #4)
Created attachment 178404 [details] [review] Bug 32051: (follow-up) Make the same change to page title
Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Great. Thanks -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Paul Derscheid <paul.derscheid@lmscloud.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #178403|0 |1 is obsolete| | --- Comment #6 from Paul Derscheid <paul.derscheid@lmscloud.de> --- Created attachment 179051 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=179051&action=edit Bug 32051: Rename Library to Contact for one public library Note: I am using $rs in the script to prevent searching branches again unneeded. And pass public_count to opac-library.tt to prevent another call of Branches.all (for bread crumbs), like masthead already does btw. Test plan: [1] Have two (or more) public libraries. Verify that you see Libraries on the OPAC home page and that when clicking Libraries, you first have the library list. Are the bread crumbs as expected? Click a library on that list. Do you get its details? Are the bread crumbs as expected? [2] Now have only one public library. Verify that you see Contact on the home page. And that when clicking Contact you go directly to the library details without the intermediate library list. Are the bread crumbs still as expected (with Contact instead of Libraries)? Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> Signed-off-by: Owen Leonard <oleonard@myacpl.org> Signed-off-by: Paul Derscheid <paul.derscheid@lmscloud.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Paul Derscheid <paul.derscheid@lmscloud.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #178404|0 |1 is obsolete| | --- Comment #7 from Paul Derscheid <paul.derscheid@lmscloud.de> --- Created attachment 179052 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=179052&action=edit Bug 32051: (follow-up) Make the same change to page title Signed-off-by: Owen Leonard <oleonard@myacpl.org> Signed-off-by: Paul Derscheid <paul.derscheid@lmscloud.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Paul Derscheid <paul.derscheid@lmscloud.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |paul.derscheid@lmscloud.de Status|Signed Off |Passed QA QA Contact|testopia@bugs.koha-communit |paul.derscheid@lmscloud.de |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Rename Library homepage |Rename 'Library' page link |link to Contact for single |to 'Contact' for single |library |library -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to main Version(s)| |25.05.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 --- Comment #8 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Pushed for 25.05! Well done everyone, thank you! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Text to go in the| |If there is only one release notes| |library marked as 'public' | |in the library | |configuration page, the | |navigation item on the OPAC | |will change from | |'Libraries' to 'Contact'. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to main |Needs documenting CC| |fridolin.somers@biblibre.co | |m --- Comment #9 from Fridolin Somers <fridolin.somers@biblibre.com> --- Enhancement not pushed to 24.11.x -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32051 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Documentation| |https://gitlab.com/koha-com submission| |munity/koha-manual/-/merge_ | |requests/1102 Status|Needs documenting |RESOLVED Documentation| |Caroline Cyr La Rose contact| | Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org