[Bug 30855] New: Rename /import => /import_batches
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Bug ID: 30855 Summary: Rename /import => /import_batches Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: REST API Assignee: koha-bugs@lists.koha-community.org Reporter: tomascohen@gmail.com CC: tomascohen@gmail.com It will keep things more consistent once we add routes to deal with import batches. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |ASSIGNED QA Contact| |martin.renvoize@ptfs-europe | |.com Depends on| |30854 Assignee|koha-bugs@lists.koha-commun |tomascohen@gmail.com |ity.org | Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30854 [Bug 30854] Missing description for 'import_record_matches' in swagger.yaml -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch Status|ASSIGNED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 --- Comment #1 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Created attachment 135384 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=135384&action=edit Bug 30855: Rename /import => /import_batches This patch renames the route to make it consistent for future additions. To test: 1. Run $ git grep 'matches/chosen' => FAIL: all occurences use /api/v1/import/ 2. Apply this patch 3. Run: $ git grep 'matches/chosen' => SUCCESS: All occurences have '/api/v1/import_batches/' 4. Run: $ kshell k$ prove t/db_dependent/api/v1/import_record_matches.t => SUCCESS: Tests pass! 5. Sign off :-D Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 --- Comment #2 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Created attachment 135385 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=135385&action=edit Bug 30855: (follow-up) Rewrite tests using Basic authentication Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #135384|0 |1 is obsolete| | --- Comment #3 from David Nind <david@davidnind.com> --- Created attachment 135412 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=135412&action=edit Bug 30855: Rename /import => /import_batches This patch renames the route to make it consistent for future additions. To test: 1. Run $ git grep 'matches/chosen' => FAIL: all occurences use /api/v1/import/ 2. Apply this patch 3. Run: $ git grep 'matches/chosen' => SUCCESS: All occurences have '/api/v1/import_batches/' 4. Run: $ kshell k$ prove t/db_dependent/api/v1/import_record_matches.t => SUCCESS: Tests pass! 5. Sign off :-D Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #135385|0 |1 is obsolete| | --- Comment #4 from David Nind <david@davidnind.com> --- Created attachment 135413 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=135413&action=edit Bug 30855: (follow-up) Rewrite tests using Basic authentication Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Victor Grousset/tuxayo <victor@tuxayo.net> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA CC| |victor@tuxayo.net --- Comment #5 from Victor Grousset/tuxayo <victor@tuxayo.net> --- Can we have a comment or a variable so the magic number 13 for flags isn't magic anymore? Otherwise, looks good for QA. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #135413|0 |1 is obsolete| | --- Comment #6 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Created attachment 135515 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=135515&action=edit Bug 30855: (follow-up) Rewrite tests using Basic authentication Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|martin.renvoize@ptfs-europe |victor@tuxayo.net |.com | Status|Failed QA |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #135412|0 |1 is obsolete| | --- Comment #7 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 135585 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=135585&action=edit Bug 30855: Rename /import => /import_batches This patch renames the route to make it consistent for future additions. To test: 1. Run $ git grep 'matches/chosen' => FAIL: all occurences use /api/v1/import/ 2. Apply this patch 3. Run: $ git grep 'matches/chosen' => SUCCESS: All occurences have '/api/v1/import_batches/' 4. Run: $ kshell k$ prove t/db_dependent/api/v1/import_record_matches.t => SUCCESS: Tests pass! 5. Sign off :-D Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Nick Clemens <nick@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #135515|0 |1 is obsolete| | --- Comment #8 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 135586 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=135586&action=edit Bug 30855: (follow-up) Rewrite tests using Basic authentication Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Nick Clemens <nick@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |22.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 --- Comment #9 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Pushed to master for 22.11. Nice work everyone, thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |Pushed to stable Version(s)|22.11.00 |22.11.00, 22.05.01 released in| | CC| |lucas@bywatersolutions.com --- Comment #10 from Lucas Gass <lucas@bywatersolutions.com> --- Pushed to 22.05.x for 22.05.01 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 --- Comment #11 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to Lucas Gass from comment #10)
Pushed to 22.05.x for 22.05.01
Thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30855 Arthur Suzuki <arthur.suzuki@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |arthur.suzuki@biblibre.com Status|Pushed to stable |RESOLVED Resolution|--- |FIXED --- Comment #12 from Arthur Suzuki <arthur.suzuki@biblibre.com> --- depends on 30854 (released in 22.05) not relevant for 21.11.x -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org