[Bug 22098] New: Update stocknumberAV cataloguing plugin
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Bug ID: 22098 Summary: Update stocknumberAV cataloguing plugin Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Cataloging Assignee: koha-bugs@lists.koha-community.org Reporter: josef.moravec@gmail.com QA Contact: testopia@bugs.koha-community.org CC: m.de.rooy@rijksmuseum.nl Target Milestone: --- This plugin could be updated to use Koha::Object instead of SQL queries. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 --- Comment #1 from Josef Moravec <josef.moravec@gmail.com> --- Created attachment 83776 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=83776&action=edit Bug 22098: Update stocknumberAV cataloguing plugin to use objects This patch: - changes SQL to Koha::AuthorisedValues - remove type param from script tag - fixes the plugin description 0) Do not apply the patch 1) Set the plugin 1.1) Update a biblio framework and link plugin stocknumberAV.pl to some item subfield 1.2) Add authorised values category called "INVENTORY" 1.3) Add some authorised values: authorised value is prefix and description is a current stock/inventory number 2) Add an item and try to use this plugin to ensure you set it correctly 2.1) Use a defined prefix to see if the number is correct 2.2) Ensure the number is correctly incremented in authorised values 2.3) Use not defined prefix to see the error message 2.4) Insert a not prefix string (eg number) to see it is not changed 3) Apply the patch 4) Repeat 2) and see it is working the same 5) Look into patch and confirm the description does make sense and is rigth according to what you see in UI 6) Sign off :D -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |josef.moravec@gmail.com |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |22126 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22126 [Bug 22126] OMNIBUS: Update cataloguing plugins -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Michal Denar <black23@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |black23@gmail.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 --- Comment #2 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 91421 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=91421&action=edit Bug 22098: (follow-up) fix grammar/formating Perldoc - nubers => numbers - some vertical spacing - !}fmt -w65 - "contains of letters" => "containing letters" TEST PLAN --------- perldoc cataloguing/value_builder/stocknumberAV.pl apply patch perldoc cataloguing/value_builder/stocknumberAV.pl -- after the patch is more readable. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Small patch Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #83776|0 |1 is obsolete| | --- Comment #3 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- Created attachment 101329 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=101329&action=edit Bug 22098: Update stocknumberAV cataloguing plugin to use objects This patch: - changes SQL to Koha::AuthorisedValues - remove type param from script tag - fixes the plugin description 0) Do not apply the patch 1) Set the plugin 1.1) Update a biblio framework and link plugin stocknumberAV.pl to some item subfield 1.2) Add authorised values category called "INVENTORY" 1.3) Add some authorised values: authorised value is prefix and description is a current stock/inventory number 2) Add an item and try to use this plugin to ensure you set it correctly 2.1) Use a defined prefix to see if the number is correct 2.2) Ensure the number is correctly incremented in authorised values 2.3) Use not defined prefix to see the error message 2.4) Insert a not prefix string (eg number) to see it is not changed 3) Apply the patch 4) Repeat 2) and see it is working the same 5) Look into patch and confirm the description does make sense and is rigth according to what you see in UI 6) Sign off :D Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #91421|0 |1 is obsolete| | --- Comment #4 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- Created attachment 101330 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=101330&action=edit Bug 22098: (follow-up) fix grammar/formating Perldoc - nubers => numbers - some vertical spacing - !}fmt -w65 - "contains of letters" => "containing letters" TEST PLAN --------- perldoc cataloguing/value_builder/stocknumberAV.pl apply patch perldoc cataloguing/value_builder/stocknumberAV.pl -- after the patch is more readable. Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |fridolin.somers@biblibre.co | |m --- Comment #5 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- Looks good, nice job -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #101329|0 |1 is obsolete| | --- Comment #6 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 101373 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=101373&action=edit Bug 22098: Update stocknumberAV cataloguing plugin to use objects This patch: - changes SQL to Koha::AuthorisedValues - remove type param from script tag - fixes the plugin description 0) Do not apply the patch 1) Set the plugin 1.1) Update a biblio framework and link plugin stocknumberAV.pl to some item subfield 1.2) Add authorised values category called "INVENTORY" 1.3) Add some authorised values: authorised value is prefix and description is a current stock/inventory number 2) Add an item and try to use this plugin to ensure you set it correctly 2.1) Use a defined prefix to see if the number is correct 2.2) Ensure the number is correctly incremented in authorised values 2.3) Use not defined prefix to see the error message 2.4) Insert a not prefix string (eg number) to see it is not changed 3) Apply the patch 4) Repeat 2) and see it is working the same 5) Look into patch and confirm the description does make sense and is rigth according to what you see in UI 6) Sign off :D Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #101373|0 |1 is obsolete| | --- Comment #7 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 101374 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=101374&action=edit Bug 22098: Update stocknumberAV cataloguing plugin to use objects This patch: - changes SQL to Koha::AuthorisedValues - remove type param from script tag - fixes the plugin description 0) Do not apply the patch 1) Set the plugin 1.1) Update a biblio framework and link plugin stocknumberAV.pl to some item subfield 1.2) Add authorised values category called "INVENTORY" 1.3) Add some authorised values: authorised value is prefix and description is a current stock/inventory number 2) Add an item and try to use this plugin to ensure you set it correctly 2.1) Use a defined prefix to see if the number is correct 2.2) Ensure the number is correctly incremented in authorised values 2.3) Use not defined prefix to see the error message 2.4) Insert a not prefix string (eg number) to see it is not changed 3) Apply the patch 4) Repeat 2) and see it is working the same 5) Look into patch and confirm the description does make sense and is rigth according to what you see in UI 6) Sign off :D Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #101330|0 |1 is obsolete| | --- Comment #8 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 101375 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=101375&action=edit Bug 22098: (follow-up) fix grammar/formating Perldoc - nubers => numbers - some vertical spacing - !}fmt -w65 - "contains of letters" => "containing letters" TEST PLAN --------- perldoc cataloguing/value_builder/stocknumberAV.pl apply patch perldoc cataloguing/value_builder/stocknumberAV.pl -- after the patch is more readable. Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 --- Comment #9 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 101376 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=101376&action=edit Bug 22098: (QA follow-up) Improving documentation Improves the documentation of the script a bit, but makes one important change: -If no prefix is submitted, or prefix does not contain only -numbers, it returns the inserted code (= keep a field unchanged) +If no prefix is submitted, or the prefix does contain only +numbers, it returns the inserted code (= keep the field unchanged). To test: - Add an authorised INVENTORY value with 2020 as prefix - After linking the stocknumberAV.pl to the 952$i in the frameworks - Edit an item - Add 2020 in the stocknumber field - Trigger plugin - Verify nothing happens If the prefix contains only numbers... nothing happens. Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |20.05.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 --- Comment #10 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Nice work everyone! Pushed to master for 20.05 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Joy Nelson <joy@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |joy@bywatersolutions.com --- Comment #11 from Joy Nelson <joy@bywatersolutions.com> --- enhancement not backported to 19.11.x -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22098 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com Severity|enhancement |normal Summary|Update stocknumberAV |The stocknumberAV |cataloguing plugin |cataloguing plugin should | |be updated to use | |Koha::Objects Component|Cataloging |Architecture, internals, | |and plumbing -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org