[Bug 15494] Block renewals by arbitrary item values
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15494 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Failed QA CC| |jonathan.druart@bugs.koha-c | |ommunity.org --- Comment #39 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- 1. In tests, prefer Koha::IssuingRules->search->update($what_you_need_to_be_set); instead of the DELETE then INSERT. It makes the changes more readable in my opinion. 2. What about "NULL" string values? :) 3. Should not we have the same code for OpacHiddenItems and ItemsDeniedRenewal (and UpdateNotForLoanStatusOnCheckin?) There is also UpdateItemLocationOnCheckin (bug 14576) The minimum would be a new get_rules_from_prefs sub Marking as FQA for discussion -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org