[Bug 30385] New: Standardize our swagger yaml spec files
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 Bug ID: 30385 Summary: Standardize our swagger yaml spec files Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: jonathan.druart+koha@gmail.com QA Contact: testopia@bugs.koha-community.org Depends on: 29810 Quotes vs no quotes, keys order, etc. We should load the file and dump them, and add a test to make sure we are not going to insert more inconsistencies. Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29810 [Bug 29810] Add embed options documentation -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 --- Comment #1 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 133110 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=133110&action=edit Bug 30385: Standardize our swagger yaml spec files -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 --- Comment #2 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 133111 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=133111&action=edit Script to generate -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff CC| |martin.renvoize@ptfs-europe | |.com, tomascohen@gmail.com Assignee|koha-bugs@lists.koha-commun |jonathan.druart+koha@gmail. |ity.org |com --- Comment #3 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Tomas, Martin, do we want that? If so it's now, it will be a nightmare to rebase. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 --- Comment #4 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- I like consistency.. looks good to me :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 Bug 30385 depends on bug 29810, which changed state. Bug 29810 Summary: Add embed options documentation https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29810 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on|29810 |30536 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29810 [Bug 29810] Add embed options documentation https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30536 [Bug 30536] Embeds should be defined in a single place -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Patch doesn't apply Assignee|jonathan.druart+koha@gmail. |koha-bugs@lists.koha-commun |com |ity.org --- Comment #5 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Now conflicting with bug 30536. No idea was the deps have been reversed. Abandoning it as it's a mess to rebase and wasn't supposed to wait that much in the queue. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 --- Comment #6 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Now conflicting with bug 30536. No idea why the deps have been reversed. I am abandoning it as it's a mess to rebase and it wasn't supposed to wait that much in the queue. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 --- Comment #7 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- I'm less sure about this now.. having delved through it I don't like how we re-order the keys within the parameters block.. We were pretty consistently as below: parameters: - name: x-koha-embed in: header description: Embed list sent as request header required: false type: array items: enum: - extended_attributes type: string collectionFormat: csv This now comes out as: parameters: - collectionFormat: csv description: Embed list send as request header in: header items: enum: - extened_attributes type: string name: x-koha-embed required: false type: array I find the second much harder to read at a glance. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 --- Comment #8 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- That's why I reversed the dependencies.. because I felt there was still work to be done here. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 --- Comment #9 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- I am failing at writing a script that will order the second (and more) level or keys. Help welcomed! :) Might be a Friday effect. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30385 Bug 30385 depends on bug 30536, which changed state. Bug 30536 Summary: Embeds should be defined in a single place https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30536 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org