[Bug 14868] REST API: Swagger2-driven permission checking
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14868 --- Comment #11 from Lari Taskula <larit@student.uef.fi> --- Created attachment 52963 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=52963&action=edit Bug 14868: Rename 'x-koha-permission' to 'x-koha-authorization' Since we need to be able to define other authorization options than simply Koha permissions, for example "allow-owner", we should rename x-koha-permission into x-koha-authorization to better describe the object. This patch simply renames all occurences of x-koha-permission into x-koha-authorization. The new specification for authorization: "/patrons/{borrowernumber}": { .. "x-koha-authorization": { "allow-owner": "1", "pemissions": { "borrowers": "1" } } } -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org