[Bug 13201] New: GetSuggestion takes suggestionid
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 Bug ID: 13201 Summary: GetSuggestion takes suggestionid Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: gmcharlt@gmail.com Reporter: jonathan.druart@biblibre.com QA Contact: testopia@bugs.koha-community.org The pod and the variable names are wrong! This could be dangerous. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 --- Comment #1 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 33243 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=33243&action=edit Bug 13201: GetSuggestion takes suggestionid Test plan: Verify the tests for suggestions still passed and that the changes are consistent (just looking at the code). -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff Patch complexity|--- |Trivial patch Assignee|gmcharlt@gmail.com |jonathan.druart@biblibre.co | |m -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #33243|0 |1 is obsolete| | --- Comment #2 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 33282 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=33282&action=edit [SIGNED OFF] Bug 13201: GetSuggestion takes suggestionid Having $ordernumber as the parameter in a function which is handling suggestions and it is used as a suggestion id is confusing to the coder and person trying to read the code. This patch corrects the confusion. REVISED TEST PLAN ----------------- 1) perldoc C4::Suggestions -- notice it says ordernumber for the GetSuggestions example. 2) Ensure you have CPL in your branches table. 3) prove -v t/db_dependent/Suggestions.t -- if you have more than 8 itemtypes in your database, two tests at the end will fail, but that is not relevant to the modified GetSuggestions code. 4) apply patch 5) perldoc C4::Suggestions -- notice it is corrected now. 6) prove -v t/db_dependent/Suggestions.t -- it should run with the same results as in step 3. That is, if you have 8 itemtypes, all pass, otherwise those two tests fail. 7) run koha qa test tool Signed-off-by: Mark Tompsett <mtompset@hotmail.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #33282|0 |1 is obsolete| | --- Comment #3 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 33349 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=33349&action=edit [PASSED QA] Bug 13201: GetSuggestion takes suggestionid Having $ordernumber as the parameter in a function which is handling suggestions and it is used as a suggestion id is confusing to the coder and person trying to read the code. This patch corrects the confusion. REVISED TEST PLAN ----------------- 1) perldoc C4::Suggestions -- notice it says ordernumber for the GetSuggestions example. 2) Ensure you have CPL in your branches table. 3) prove -v t/db_dependent/Suggestions.t -- if you have more than 8 itemtypes in your database, two tests at the end will fail, but that is not relevant to the modified GetSuggestions code. 4) apply patch 5) perldoc C4::Suggestions -- notice it is corrected now. 6) prove -v t/db_dependent/Suggestions.t -- it should run with the same results as in step 3. That is, if you have 8 itemtypes, all pass, otherwise those two tests fail. 7) run koha qa test tool Signed-off-by: Mark Tompsett <mtompset@hotmail.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master CC| |tomascohen@gmail.com --- Comment #4 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Patch pushed to master. Thanks Jonathan! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 Chris Cormack <chris@bigballofwax.co.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |chris@bigballofwax.co.nz Status|Pushed to Master |Pushed to Stable --- Comment #5 from Chris Cormack <chris@bigballofwax.co.nz> --- Pushed to 3.18.x will be in 3.18.4 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |rel_3_16_candidate CC| |mtj@kohaaloha.com --- Comment #6 from Mason James <mtj@kohaaloha.com> --- Pushed to 3.16.x, will be in 3.16.8 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13201 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|rel_3_16_candidate | -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org