[Bug 18641] New: Translatability: Get rid of template directives in translations for *reserves.tt files
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Bug ID: 18641 Summary: Translatability: Get rid of template directives in translations for *reserves.tt files Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: I18N/L10N Assignee: koha-bugs@lists.koha-community.org Reporter: veron@veron.ch QA Contact: testopia@bugs.koha-community.org CC: frederic@tamil.fr -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #1 from Marc Véron <veron@veron.ch> --- Template directives should not be exposed in translation, but lines like the following pop up in the translation tool: Cancel [% IF TransferWhenCancelAllWaitingHolds %]and Transfer [% END %] All -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #2 from Marc Véron <veron@veron.ch> --- Created attachment 63584 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=63584&action=edit Bug 18641 - Translatability: Get rid of template directives in translations for *reserves.tt files Template directives should not be exposed in translation, but lines like the following pop up in the translation tool: Cancel [% IF TransferWhenCancelAllWaitingHolds %]and Transfer [% END %] All This patch fixes it. To test: - Apply patch - Verify that code changes make sense - Verify that submit buttons of pendingreserves.tt and waitingreserves.tt still work and display the same string as before -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Marc Véron <veron@veron.ch> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |String patch Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Marc Véron <veron@veron.ch> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |veron@veron.ch |ity.org | -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #63584|0 |1 is obsolete| | --- Comment #3 from Josef Moravec <josef.moravec@gmail.com> --- Created attachment 63608 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=63608&action=edit [SIGNED-OFF] Bug 18641 - Translatability: Get rid of template directives in translations for *reserves.tt files Template directives should not be exposed in translation, but lines like the following pop up in the translation tool: Cancel [% IF TransferWhenCancelAllWaitingHolds %]and Transfer [% END %] All This patch fixes it. To test: - Apply patch - Verify that code changes make sense - Verify that submit buttons of pendingreserves.tt and waitingreserves.tt still work and display the same string as before Signed-off-by: Josef Moravec <josef.moravec@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #4 from Marc Véron <veron@veron.ch> --- Created attachment 63625 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=63625&action=edit Bug 18649: Translatability: Get rid of tt directive in translation for admin/categories.tt and onboardingstep2.tt Translation tool shows [% IF category.enrolmentperiod %][% category.enrolmentperiod %][% END %] for en/modules/admin/categories.tt and koha-tmpl/intranet-tmpl/prog/en/modules/onboarding/onboardingstep2.tt This patch fixes it. To test: - Apply patch - Verify that code changes make sense - Verify that template directive is no longer picked by translation -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Marc Véron <veron@veron.ch> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #63625|0 |1 is obsolete| | --- Comment #5 from Marc Véron <veron@veron.ch> --- Comment on attachment 63625 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=63625 Bug 18649: Translatability: Get rid of tt directive in translation for admin/categories.tt and onboardingstep2.tt Sorry for the noise, I mistaked in Bug number... -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #63608|0 |1 is obsolete| | --- Comment #6 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 63928 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=63928&action=edit Bug 18641 - Translatability: Get rid of template directives in translations for *reserves.tt files Template directives should not be exposed in translation, but lines like the following pop up in the translation tool: Cancel [% IF TransferWhenCancelAllWaitingHolds %]and Transfer [% END %] All This patch fixes it. To test: - Apply patch - Verify that code changes make sense - Verify that submit buttons of pendingreserves.tt and waitingreserves.tt still work and display the same string as before Signed-off-by: Josef Moravec <josef.moravec@gmail.com> Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |m.de.rooy@rijksmuseum.nl QA Contact|testopia@bugs.koha-communit |m.de.rooy@rijksmuseum.nl |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@bugs.koha-c | |ommunity.org --- Comment #7 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- And what not something more readable like [% IF %] input [% ELSE %] other input [% END %] ? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #8 from Marc Véron <veron@veron.ch> --- Created attachment 63965 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=63965&action=edit Bug 18641: (RM-followup) for waitingreserves.tt Code changed for waitingreserves.tt as asked for in comment #7 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #9 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Marcel, what do you think? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #10 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to Jonathan Druart from comment #9)
Marcel, what do you think?
Looks good to me -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #11 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- (In reply to Marcel de Rooy from comment #10)
(In reply to Jonathan Druart from comment #9)
Marcel, what do you think?
Looks good to me
Yes I know :) But do you think the BLOCK method is acceptable, or we should stick to the IF/ELSE usual style? I am asking for the other bug reports. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #12 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to Jonathan Druart from comment #11)
(In reply to Marcel de Rooy from comment #10)
(In reply to Jonathan Druart from comment #9)
Marcel, what do you think?
Looks good to me
Yes I know :) But do you think the BLOCK method is acceptable, or we should stick to the IF/ELSE usual style? I am asking for the other bug reports.
In most cases we may be able to avoid BLOCK just as we do here now, but it might not be that easy everywhere.. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Failed QA --- Comment #13 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- For the pendingreserves changes: Before the patch, I got #. %1$s: HoldsToPullStartDate. #. %2$s: IF ( HoldsToPullEndDate ). #. %3$s: HoldsToPullEndDate. #. %4$s: ELSE. #. %5$s: END. #: intranet-tmpl/prog/en/modules/circ/pendingreserves.tt:198 #, c-format msgid "" "(Inclusive, default is %s days ago to %s%s days ahead%stoday%s, set other " "date ranges as needed. )" now I get: #. %1$s: BLOCK range_msg. #. %2$s: HoldsToPullStartDate. #. %3$s: IF ( HoldsToPullEndDate ). #. %4$s: HoldsToPullEndDate. #. %5$s: ELSE. #. %6$s: END. #. %7$s: END. #: intranet-tmpl/prog/en/modules/circ/pendingreserves.tt:197 #, fuzzy, c-format msgid "" "%s(Inclusive, default is %s days ago to %s%s days ahead%stoday%s, set other " "date ranges as needed.)%s " Seems worst... -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #14 from Marc Véron <veron@veron.ch> --- Created attachment 64078 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=64078&action=edit Bug 18641: Followup for pendingreserves.tt (less %s) Change as of comment #13 to reduce %s After creating a new translation for a "language" aa-AA, we have the following in the file aa-AA-staff-prog.po msgid "" "(Inclusive, default is %s days ago to %s days ahead. Set other date ranges " "as needed.)" msgstr "" msgid "" "(Inclusive, default is %s days ago to today. Set other date ranges as " "needed.)" msgstr "" -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Marc Véron <veron@veron.ch> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Passed QA --- Comment #15 from Marc Véron <veron@veron.ch> --- Hope it's OK to set this back to PQA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #16 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Pushed to master for 17.11, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 --- Comment #17 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- I have squashed the 3 patches for readability. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de --- Comment #18 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Squashed patch from 17.05 has been pushed to 16.11.x and will be in 16.11.09. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Severity|enhancement |trivial -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18641 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |mtj@kohaaloha.com --- Comment #19 from Mason James <mtj@kohaaloha.com> --- Pushed to 16.05.x, for 16.05.15 release -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org