[Bug 12548] New: Auth::checkauth() needs more in-line comments
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 Bug ID: 12548 Summary: Auth::checkauth() needs more in-line comments Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Documentation Assignee: nengard@gmail.com Reporter: dcook@prosentient.com.au QA Contact: testopia@bugs.koha-community.org C4::Auth::checkauth() can be a bit difficult to read. Take for instance the following code snippet unless ($userid || $sessionID) { ... } That makes it seem like this block will be executed if we haven't sent a userid in the CGI object passed to checkauth(). On the contrary, the userid in the CGI object has been defined as "$q_userid" so this block of code is actually what will be executed when we're logging in with a userid and password. The $userid mentioned in this condition refers to the "id" retrieved from an existing session or from "$userid = $ENV{'REMOTE_USER'}" (which is an environmental variable set via SIP?). So that's confusing. The whitespace is also inconsistent with the actual flow of logic, so that should be fixed up too. There are all sorts of little bits that need some explanatory comments. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|nengard@gmail.com |dcook@prosentient.com.au -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=12547 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 Indranil Das Gupta <indradg@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |indradg@gmail.com -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dpavlin@rot13.org, | |martin.renvoize@ptfs-europe | |.com Component|Documentation |Authentication -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 --- Comment #1 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Switched to authentication module as I feel inline code documentaiton should come under the specific module and I wanted it to turn up in my Authentcation Module Maintainer search ;). I agree Auth.pm needs better inline documentation, and I intend to add it during this cycle given the time. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |13499 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |13503 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on|13503 | -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12548 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |13521 -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org