[Bug 29762] New: Patron batch modification tool - column
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Bug ID: 29762 Summary: Patron batch modification tool - column Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: minor Priority: P5 - low Component: Tools Assignee: koha-bugs@lists.koha-community.org Reporter: david@davidnind.com QA Contact: testopia@bugs.koha-community.org When modifying patron information using the patron batch modification tool (Tools > Patrons > Patron batch modification), the listing pages after entering either card numbers or borrower numbers have a 'Mobile' column. This matches to 'Other phone' in the contact information section when editing patron information. This is not the same as the SMS number when SMS for messages is enabled. Should this remain as 'Mobile" or be changed to match the patron information field title? Or vice versa? This was identified when testing bug 23291 - Patron batch modification based on SMS number. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Patron batch modification |Patron batch modification |tool - column |tool - mobile phone number | |column naming -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=23291 -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart+koha@gmail. | |com Keywords| |Academy --- Comment #1 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Yes, should be renamed "Other phone" -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Philip Orr <philip.orr@lmscloud.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |philip.orr@lmscloud.de Assignee|koha-bugs@lists.koha-commun |philip.orr@lmscloud.de |ity.org | Status|NEW |ASSIGNED -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Philip Orr <philip.orr@lmscloud.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff Patch complexity|--- |String patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 --- Comment #2 from Philip Orr <philip.orr@lmscloud.de> --- Created attachment 153181 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=153181&action=edit Bug 29762: Change field names from "Mobile" to "Other phone" This Patch changes the field name for "Mobile" to "Other phone" in Patron batch modification. To test: 1. Apply the patch 2. Go to Tools -> Batch Patron Modification and add some patrons 3. Hit "continue" 4. Verify that in the list of patrons you selected, the field "Mobile" has been replaced by the field "Other phone" 5. Verify that down below in the fields to be batch modified, the field "Mobile" has also been replaced by the field "Other phone" 6. Add some data into the field "Other phone" (e.g. 12345 or some other number) and hit save 7. Confirm that the field was correctly modified and is still named "Other phone" -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 --- Comment #3 from Philip Orr <philip.orr@lmscloud.de> --- Just a quick note on this patch: I only changed the name of the field in modborrowers.tt, I made no changes to the database. The actual database field in borrowers that is displayed in "Other phone" is (possibly confusingly) named borrowers.mobile. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Sam Lau <samalau@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Sam Lau <samalau@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #153181|0 |1 is obsolete| | --- Comment #4 from Sam Lau <samalau@gmail.com> --- Created attachment 153192 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=153192&action=edit Bug 29762: Change field names from "Mobile" to "Other phone" This Patch changes the field name for "Mobile" to "Other phone" in Patron batch modification. To test: 1. Apply the patch 2. Go to Tools -> Batch Patron Modification and add some patrons 3. Hit "continue" 4. Verify that in the list of patrons you selected, the field "Mobile" has been replaced by the field "Other phone" 5. Verify that down below in the fields to be batch modified, the field "Mobile" has also been replaced by the field "Other phone" 6. Add some data into the field "Other phone" (e.g. 12345 or some other number) and hit save 7. Confirm that the field was correctly modified and is still named "Other phone" Signed-off-by: Sam Lau <samalau@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |katrin.fischer@bsz-bw.de |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 --- Comment #5 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Philip Orr from comment #3)
Just a quick note on this patch: I only changed the name of the field in modborrowers.tt, I made no changes to the database. The actual database field in borrowers that is displayed in "Other phone" is (possibly confusingly) named borrowers.mobile.
That's confusing, but ok. We try to make the descriptions match between the normal patron form and the batch patron modification. Other phone in GUI is mobile in the database since some renaming of fields took place a long while ago. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #153192|0 |1 is obsolete| | --- Comment #6 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 153218 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=153218&action=edit Bug 29762: Change field names from "Mobile" to "Other phone" This Patch changes the field name for "Mobile" to "Other phone" in Patron batch modification. To test: 1. Apply the patch 2. Go to Tools -> Batch Patron Modification and add some patrons 3. Hit "continue" 4. Verify that in the list of patrons you selected, the field "Mobile" has been replaced by the field "Other phone" 5. Verify that down below in the fields to be batch modified, the field "Mobile" has also been replaced by the field "Other phone" 6. Add some data into the field "Other phone" (e.g. 12345 or some other number) and hit save 7. Confirm that the field was correctly modified and is still named "Other phone" Signed-off-by: Sam Lau <samalau@gmail.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 --- Comment #7 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 153219 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=153219&action=edit Bug 29762: (follow-up) Change field names from phone to primary phone This change is made in order to make sure that the labels on the normal patron form and the batch patron edit tool match up. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)| |23.11.00 released in| | Status|Passed QA |Pushed to master -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 --- Comment #8 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Pushed to master for 23.11. Nice work everyone, thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |Pushed to stable Version(s)|23.11.00 |23.11.00,23.05.02 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 --- Comment #9 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Thanks for all the hard work! Pushed to 23.05.x for the next release -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to stable |Pushed to oldstable Version(s)|23.11.00,23.05.02 |23.11.00,23.05.02,22.11.08 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 --- Comment #10 from Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> --- Nice work everyone! Pushed to oldstable for 22.11.x -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29762 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |FIXED Status|Pushed to oldstable |RESOLVED CC| |lucas@bywatersolutions.com -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org