[Bug 26718] New: Change 'Your Reading History" to "Your Checkout History"
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Bug ID: 26718 Summary: Change 'Your Reading History" to "Your Checkout History" Change sponsored?: --- Product: Koha Version: 19.11 Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: OPAC Assignee: oleonard@myacpl.org Reporter: barbara.johnson@bedfordtx.gov QA Contact: testopia@bugs.koha-community.org In the OPAC "Your Reading History" seems misnamed since patrons also check out DVDs, music, audio books, kits, library of things, etc. It seems like a more accurate name would be "Your Checkout History" -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Change 'Your Reading |Change 'Your reading |History" to "Your Checkout |history" to "Your checkout |History" |history" --- Comment #1 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Hi Barbara, first of all: thx for all the bug reports! I think you have a very good point here. +1 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff Patch complexity|--- |String patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 --- Comment #2 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 111942 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=111942&action=edit Bug 26718: Rename "reading history" to "checkout history" This changes all occurences of reading history to the more accurate term 'checokut history' as it was correctly pointed out that 'reading' doesn't apply to all kind of items available at the library (audio books, games, etc.) To test: - Verify that the term reding history has been replaced by checkout history in: - System preferences - OPAC tab "your checkout history" - OPAC tab "your privacy" (switch OpacPrivacy pref first) - Staff permission for patron batch anonymization -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Version|19.11 |master Keywords| |Academy Assignee|oleonard@myacpl.org |katrin.fischer@bsz-bw.de --- Comment #3 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I've written up a patch with the suggested change - please check and discuss! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 --- Comment #4 from Barbara Johnson <barbara.johnson@bedfordtx.gov> --- Everything worked for me except the change for the system preferences. They still display as opacreadinghistory and intranetreadinghistory. Also still displays opacreadinghistory in the description for the StoreLastBorrower system preference. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 --- Comment #5 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Hi Barbara, thx for testing. I didn't rename the preferences, only changed the description texts and labels in the GUI. Renaming the prefs would require more work and they are only visible to system librarians, so hope I can get away with that :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 ByWater Sandboxes <bws.sandboxes@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #111942|0 |1 is obsolete| | --- Comment #6 from ByWater Sandboxes <bws.sandboxes@gmail.com> --- Created attachment 111949 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=111949&action=edit Bug 26718: Rename "reading history" to "checkout history" This changes all occurences of reading history to the more accurate term 'checokut history' as it was correctly pointed out that 'reading' doesn't apply to all kind of items available at the library (audio books, games, etc.) To test: - Verify that the term reding history has been replaced by checkout history in: - System preferences - OPAC tab "your checkout history" - OPAC tab "your privacy" (switch OpacPrivacy pref first) - Staff permission for patron batch anonymization Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Barbara Johnson <barbara.johnson@bedfordtx.gov> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off --- Comment #7 from Barbara Johnson <barbara.johnson@bedfordtx.gov> --- Katrin, thanks for clarifying that. So it all works as expected and I’ve signed off. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 --- Comment #8 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Thank you! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #111949|0 |1 is obsolete| | --- Comment #9 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 112109 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=112109&action=edit Bug 26718: Rename "reading history" to "checkout history" This changes all occurences of reading history to the more accurate term 'checokut history' as it was correctly pointed out that 'reading' doesn't apply to all kind of items available at the library (audio books, games, etc.) To test: - Verify that the term reding history has been replaced by checkout history in: - System preferences - OPAC tab "your checkout history" - OPAC tab "your privacy" (switch OpacPrivacy pref first) - Staff permission for patron batch anonymization Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov> Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com Status|Signed Off |Passed QA --- Comment #10 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Nice clarification.. Passing QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |20.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 --- Comment #11 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Pushed to master for 20.11, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |lucas@bywatersolutions.com --- Comment #12 from Lucas Gass <lucas@bywatersolutions.com> --- enhancement will not be backported to 20.05.x -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26718 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Text to go in the| |This changes "reading release notes| |history" to "checkout | |history" in the staff | |interface and OPAC as | |libraries are not only | |leanding reading materials | |but a lot of different | |media. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org