[Bug 19512] New: Koha::File - wrapper/utility routines for file handling
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 Bug ID: 19512 Summary: Koha::File - wrapper/utility routines for file handling Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: olli-antti.kivilahti@jns.fi QA Contact: testopia@bugs.koha-community.org Subroutines specific to dealing with files. Maybe some day evolve to a true wrapper for all file operations. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 --- Comment #1 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- Created attachment 68384 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=68384&action=edit Bug 19512 - Koha::File - wrapper/utility routines for file handling Add getDiagnostics() usable by Exceptions to gather more information about a file and why accessing it failed. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=19515 -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |19515 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19515 [Bug 19515] Refactor REST API session mocking to reduce code duplication -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |josef.moravec@gmail.com Status|Needs Signoff |Failed QA --- Comment #2 from Josef Moravec <josef.moravec@gmail.com> --- Olle, first I have to say I like the idea of file wrapper, I've tried to test this but: test Koha/File.t is not passing for me Both test warn: Use of uninitialized value $ENV{"KOHA_PATH"} in concatenation (.) or string koha qa tools has also some complains: FAIL Koha/Exceptions/File.pm FAIL pod =head2 without preceding higher level *** WARNING: in file Koha/Exceptions/File.pm FAIL pod coverage POD is missing for Fields POD is missing for description POD is missing for path POD is missing for stat FAIL Koha/File.pm FAIL critic "return" statement with explicit "undef" at line 36, column 5. See page 199 of PBP. FAIL pod coverage POD is missing for 'getDiagnosticsString' FAIL t/Koha/Exceptions/File.t FAIL spelling throughly ==> thoroughly FAIL t/Koha/File.t FAIL critic Integer with leading zeros: "07777" at line 20, column 50. See page 58 of PBP. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #68384|0 |1 is obsolete| | --- Comment #3 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 68452 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=68452&action=edit Bug 19512 - Koha::File - wrapper/utility routines for file handling Add getDiagnostics() usable by Exceptions to gather more information about a file and why accessing it failed. Signed-off-by: Mark Tompsett <mtompset@hotmail.com> -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 --- Comment #4 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 68453 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=68453&action=edit Bug 19512: silence noise when KOHA_PATH undefined. If you run the tests with KOHA_PATH unset, this bombs. Apply the patch, and it copes by guessing the current directory. Signed-off-by: Mark Tompsett <mtompset@hotmail.com> -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 --- Comment #5 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 68454 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=68454&action=edit Bug 19512: Make pass koha qa test tools Can't seem to get the pod coverage correct for one file. This fixes the others. Signed-off-by: Mark Tompsett <mtompset@hotmail.com> -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19512 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |mtompset@hotmail.com --- Comment #6 from M. Tompsett <mtompset@hotmail.com> --- (In reply to Josef Moravec from comment #2)
FAIL pod coverage POD is missing for Fields POD is missing for description POD is missing for path POD is missing for stat
Still Failed QA because of this. But I can't figure out where these subs are defined. It makes no sense. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org