[Bug 10305] New: Duplicate code in Search.pm
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Bug ID: 10305 Summary: Duplicate code in Search.pm Classification: Unclassified Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: trivial Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: gmcharlt@gmail.com Reporter: kyle.m.hall@gmail.com For some reason, _increment_barcode is called twice in succession in cataloguing/additem.pl -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 --- Comment #1 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 18281 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=18281&action=edit Bug 10305 - Duplicate code in Search.pm For some reason, _increment_barcode is called twice in succession in cataloguing/additem.pl Test Plan: 1) Enable autobarcode = incremental 2) Catalog an item, not the barcode 3) Apply this patch 4) Catalog another item, the barcode should be the next in line as previously. No change should be noted. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Kyle M Hall <kyle.m.hall@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|gmcharlt@gmail.com |kyle.m.hall@gmail.com -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Kyle M Hall <kyle.m.hall@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Galen Charlton <gmcharlt@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA CC| |gmcharlt@gmail.com --- Comment #2 from Galen Charlton <gmcharlt@gmail.com> --- The patch itself looks OK, the patch title is clearly wrong. Please update the patch title (and the bug title) to reflect the actual problem, which is that _increment_barcode is called twice. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #18281|0 |1 is obsolete| | --- Comment #3 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 20227 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=20227&action=edit Bug 10305 - _increment_barcode is called twice For some reason, _increment_barcode is called twice in succession in cataloguing/additem.pl Test Plan: 1) Enable autobarcode = incremental 2) Catalog an item, not the barcode 3) Apply this patch 4) Catalog another item, the barcode should be the next in line as previously. No change should be noted. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |kyle@bywatersolutions.com Summary|Duplicate code in Search.pm |_increment_barcode is | |called twice -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #20227|0 |1 is obsolete| | --- Comment #4 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 21370 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=21370&action=edit Bug 10305 - _increment_barcode is called twice For some reason, _increment_barcode is called twice in succession in cataloguing/additem.pl Test Plan: 1) Enable autobarcode = incremental 2) Catalog an item, not the barcode 3) Apply this patch 4) Catalog another item, the barcode should be the next in line as previously. No change should be noted. Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA CC| |m.de.rooy@rijksmuseum.nl QA Contact| |m.de.rooy@rijksmuseum.nl --- Comment #5 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- Works. Looks good to me. There was no problem before, just a duplicate executing of a select max in the database. Note that the code used for this increment might still be wrong with concurrent edits, since the max calculation and the update of the table are quite separate parts in code. Reminds me of the discussion about the seqno engine.. No complaints from qa tools. Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Galen Charlton <gmcharlt@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #6 from Galen Charlton <gmcharlt@gmail.com> --- Pushed to master. Thanks, Kyle! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10305 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |Pushed to Stable CC| |tomascohen@gmail.com --- Comment #7 from Tomás Cohen Arazi <tomascohen@gmail.com> --- This patch has been pushed to 3.12.x, will be in 3.12.7. Thanks Kyle! -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org