[Bug 19250] New: Add pagination to /acquisitions/vendors
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Bug ID: 19250 Summary: Add pagination to /acquisitions/vendors Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: REST api Assignee: koha-bugs@lists.koha-community.org Reporter: tomascohen@gmail.com The vendors listing endpoint should provide a way to have pagination. Should be straightforward with bug 19196. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |tomascohen@gmail.com |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |19196 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19196 [Bug 19196] Add pagination helpers -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |19369, 19370 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19369 [Bug 19369] Add a helper function for translating pagination params into SQL::Abstract https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19370 [Bug 19370] Add a helper function for translating order_by params into SQL::Abstract -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |18120 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18120 [Bug 18120] CRUD endpoint for vendors -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Bug 19250 depends on bug 18120, which changed state. Bug 18120 Summary: CRUD endpoint for vendors https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18120 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |18731 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18731 [Bug 18731] CRUD for acquisition orders -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff Depends on|18731, 19196, 19369, 19370, |19686 |18120 | Patch complexity|--- |Small patch Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18120 [Bug 18120] CRUD endpoint for vendors https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18731 [Bug 18731] CRUD for acquisition orders https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19196 [Bug 19196] Add pagination helpers https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19369 [Bug 19369] Add a helper function for translating pagination params into SQL::Abstract https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19370 [Bug 19370] Add a helper function for translating order_by params into SQL::Abstract https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19686 [Bug 19686] objects.search helper needs a to_model param -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 --- Comment #1 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Created attachment 69317 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=69317&action=edit Bug 19250: Add /acquisitions/vendors pagination This patch makes the /acquisitions/vendors endpoint paginated and handle the new special params introduced by 19410: _match, _order_by_, _page and _per_page. To do so, the OpenAPI spec is updated with the new parameters, and _to_model is rewritten to avoid autovivification, as required by the extension of the objects.search helper, introduced by bug 19686. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |19757 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19757 [Bug 19757] Add routes to handle vendor contacts -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Maksim Sen <maksim.sen@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |maksim.sen@inlibro.com --- Comment #2 from Maksim Sen <maksim.sen@inlibro.com> --- Could I have a test plan to sign off this bug? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |ASSIGNED URL| |https://wiki.koha-community | |.org/wiki/Acquisitions_vend | |ors_endpoint_RFC --- Comment #3 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to Maksim Sen from comment #2)
Could I have a test plan to sign off this bug?
Hi, I'm working on a broader rewrite of this endpoint implementing the voted RFC. https://wiki.koha-community.org/wiki/Acquisitions_vendors_endpoint_RFC -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19250 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |DUPLICATE Status|ASSIGNED |RESOLVED --- Comment #4 from Tomás Cohen Arazi <tomascohen@gmail.com> --- *** This bug has been marked as a duplicate of bug 24321 *** -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org