[Bug 16461] New: Add some information (branch and barcode) in fine description for overdue
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Bug ID: 16461 Summary: Add some information (branch and barcode) in fine description for overdue Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Patrons Assignee: koha-bugs@lists.koha-community.org Reporter: sophie.meynieux@biblibre.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com, kyle.m.hall@gmail.com Some libraries need to display item's branch code and barcode number in each fine line, set for overdues. This way librarian avoid making a mistake and collect a fine for an item that belongs to another branch. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Theodoros Theodoropoulos <theod@lib.auth.gr> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |theod@lib.auth.gr -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 --- Comment #1 from Alex Arnaud <alex.arnaud@biblibre.com> --- Created attachment 51443 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51443&action=edit Bug 16461 - Add branch and barcode in fine description for overdue -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Alex Arnaud <alex.arnaud@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff CC| |alex.arnaud@biblibre.com -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 --- Comment #2 from Theodoros Theodoropoulos <theod@lib.auth.gr> --- Thank you Alex and Sophie, this would indeed come very handy to our Koha installation. However, in the long term, (especially if this is to be used the whole community), I think it would be far better if separate columns were created in the accountlines table to hold (at least) the branchcode and/or the item barcode[1]. In the same context, an ideal situation would be if branchcode/barcode would be displayed in separate columns in the fines table (and not concatenated in the description). This way description text would not be unnecessarily long and would not include hardcoded "Branch" and "Barcode" strings (which instead would be shown as translatable table headers in the fines table). Just as food for thought :) [1] if you don't want to keep barcodes both in items and accountlines table (also useful if barcode was changed in the meantime), it could be dynamically read during fines display (using itemnumber as key) -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 --- Comment #3 from Theodoros Theodoropoulos <theod@lib.auth.gr> --- Another advantage of the 'separate columns for Branch/Barcode in fines' approach would be that instead of branch CODE, the branch NAME could be displayed in the separate "Branch" column (as it happens with other item-related tables) which is more clear to staff librarians. Of course, similarly due date could be a separate column in the fines table! So to wrap the whole idea up: My proposal for the long run would be something like: Fines & charges | Description | Barcode | Due Date | Branch | Payment note | Account type | Notify id | Level | Amount | Amount outstanding (The table seems to hold too much information to fit into the screen, but description is no longer required to be that long!) Having said that, the disadvantage of this approach is that not ALL fines are related to items, in which case Barcode and Due Date columns will be empty. If this is acceptable and you're willing to make the change in the database schema of the accountlines table, I think it would be fairly easy to implement and would worth the time and effort... -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Marc Véron <veron@veron.ch> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |veron@veron.ch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Theodoros Theodoropoulos <theod@lib.auth.gr> changed: What |Removed |Added ---------------------------------------------------------------------------- Component|Patrons |Circulation -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Theodoros Theodoropoulos <theod@lib.auth.gr> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=16639 -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 --- Comment #4 from Theodoros Theodoropoulos <theod@lib.auth.gr> --- Based on the case description, the proposed fix does the trick. However, in order to keep track of the 'more advanced' solution that we would like to have, I created separate RFE: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16639 -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Joy Nelson <joy@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Joy Nelson <joy@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #51443|0 |1 is obsolete| | --- Comment #5 from Joy Nelson <joy@bywatersolutions.com> --- Created attachment 52052 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=52052&action=edit Bug 16461 - Add branch and barcode in fine description for overdue Signed-off-by: Joy Nelson <joy@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA CC| |jonathan.druart@bugs.koha-c | |ommunity.org --- Comment #6 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- QA comments: 1/ Please add a test plan 2/ This patch adds 3 strings which are not translatable "Due", "Barcode" and "Branch". Note that "Branch" should be renamed with "Library". -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Alex Arnaud <alex.arnaud@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #52052|0 |1 is obsolete| | --- Comment #7 from Alex Arnaud <alex.arnaud@biblibre.com> --- Created attachment 61042 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=61042&action=edit Bug 16461 - Add branch and barcode in accountline table for overdues -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Alex Arnaud <alex.arnaud@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff QA Contact|testopia@bugs.koha-communit |alex.arnaud@biblibre.com |y.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |Academy CC| |katrin.fischer@bsz-bw.de -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |theod@lib.auth.gr |ity.org | -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 David Bourgault <david.bourgault@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |david.bourgault@inlibro.com --- Comment #8 from David Bourgault <david.bourgault@inlibro.com> --- Missing a test plan -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Simon Pouchol <simon.pouchol@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |simon.pouchol@biblibre.com Status|Needs Signoff |Patch doesn't apply --- Comment #9 from Simon Pouchol <simon.pouchol@biblibre.com> --- Looks like this patch doesn't apply : Applying: Bug 16461 - Add branch and barcode in accountline table for overdues Using index info to reconstruct a base tree... M C4/Overdues.pm M installer/data/mysql/kohastructure.sql M koha-tmpl/intranet-tmpl/prog/en/modules/members/pay.tt M t/db_dependent/Circulation.t Falling back to patching base and 3-way merge... Auto-merging t/db_dependent/Circulation.t CONFLICT (content): Merge conflict in t/db_dependent/Circulation.t Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/members/pay.tt Auto-merging installer/data/mysql/kohastructure.sql Auto-merging C4/Overdues.pm error: Failed to merge in the changes. Patch failed at 0001 Bug 16461 - Add branch and barcode in accountline table for overdues -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Cab Vinton <bibliwho@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |bibliwho@gmail.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |19066 CC| |martin.renvoize@ptfs-europe | |.com --- Comment #10 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- This is a partial duplicate of bug 19066 (which adds branchcode to the accountlines table) Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19066 [Bug 19066] Add branchcode to accountlines -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 --- Comment #11 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- QA Comment: The SQL side of this is now basically covered by bug 19066 for branchcode and I would prefer not to add barcode from the items table alongside the existing item_id.. you can just use a simple join to get the barcode ;). Please can this be updated to depend upon 19066 if we still want the included UI changes here. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Bug 16461 depends on bug 19066, which changed state. Bug 19066 Summary: Add branchcode to accountlines https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19066 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Marjorie Barry-Vila <marjorie.barry-vila@collecto.ca> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |marjorie.barry-vila@collect | |o.ca -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Wendy Sharkey <catalog@bfli.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |catalog@bfli.org --- Comment #12 from Wendy Sharkey <catalog@bfli.org> --- It would be useful if this table contained more information in general. We have a job identifying what type of item has a fine. Quite often we will have book, audio and movie of the same item. Rather than have to explore the system to get that information by including the item type and call number all the information would be collected together when you need it. We are part of a consortium so knowing which library the item belongs to would help us to know if a payment needs forwarding to a different library. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Patch doesn't apply |ASSIGNED Summary|Add some information |Add barcode and item type |(branch and barcode) in |in fine description for |fine description for |overdue |overdue | --- Comment #13 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Updated to reflect changes on master and comments. Setting back to NEW for now, as I think this will require a different/new approach than the existing patch. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |NEW -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 --- Comment #14 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- *** Bug 16639 has been marked as a duplicate of this bug. *** -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Theodoros Theodoropoulos <theod@lib.auth.gr> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|theod@lib.auth.gr |koha-bugs@lists.koha-commun | |ity.org -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=24865 -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16461 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|Academy | Resolution|--- |FIXED Status|NEW |RESOLVED --- Comment #15 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- This is possible now using OVERDUE_FINE_DESC in 'notices and slips'. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org