[Bug 12310] Decimal separators issues in patrons payments/fines
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12310 --- Comment #96 from Victor Grousset/tuxayo <victor.grousset@biblibre.com> --- (In reply to Marcel de Rooy from comment #95)
Very brave to take this upon you !
Thanks Marcel :)
Tiny suggestion: .decimal-unformating Fix spelling please. At least t => tt
Indeed >< thanks for catching this. QA++ :) TODO implement
but what is decimal unformat btw?
I followed this example: https://metacpan.org/pod/Number::Format#unformat_number($formatted)
Better name? Something with normalize or so??
.number-normalizing .number-normalizer .number-normalize .decimal-normalizing .decimal-normalizer .decimal-normalize Which one would be good enough? TODO wait answer, blocking question
I have the feeling that DecimalSeparators and CurrencyFormat don't really harmonize. And yes, I can understand how problematic making changes in this area must be..
So thousands separators come at the expense of handling both dots and commas. Still opt for something that is more understandable.
I'm not sure to understand. Is the the current state the patch on this topic acceptable?
The number of changes to be expected here would be much larger. You actually use the new js formatting in three acq templates. What about things like: [...] And this is just to name a few; the list could probably be larger when searching harder. It might be impossible to make global changes but the risk of this is adding just another approach in a few places and leaving Koha even more fragmented on the subject?
I split the patch because the test plan was way too long. http://irc.koha-community.org/koha/2018-03-30#i_2024887 http://irc.koha-community.org/koha/2018-03-30#i_2024900 When this bug and bug 18723[1] will be in master there won't be more fragmentation than today. And less actually. locally: acquisitions and payments/fines will be internally less fragmented. as there are currently different behaviors in *successive pages* [2] globally: the new approach replaces an existing one (I checked that it not used elsewhere) see moneyFormat function. https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=75127&action=diff So, are these changes a step in the right direct worth of begin integrated? TODO wait answer, blocking question [1] which will also apply these changes to aqbudgetperiods.tt aqbudgets.tt in addition of the pages concerned by the bug description. [2] a big reason of why I get the most requests to fix decimal sep issues in these views -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org