[Bug 7291] New: claims management improvement
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Bug #: 7291 Summary: claims management improvement Classification: Unclassified Change sponsored?: Sponsored Product: Koha Version: rel_3_8 Platform: All OS/Version: All Status: NEW Severity: enhancement Priority: P5 - low Component: Acquisitions AssignedTo: claire.hernandez@biblibre.com ReportedBy: claire.hernandez@biblibre.com QAContact: ian.walls@bywatersolutions.com Blocks: 7163 claim: button "check all" & estimated date. Add a button to "check all" on the acquisition claim page. A filter on estimated dates will be added (BibLibre MT6546) -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 --- Comment #1 from Katrin Fischer <katrin.fischer@bsz-bw.de> 2012-01-22 17:44:18 UTC --- Created attachment 7277 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=7277 screenshot Links to "check all/uncheck all" orders from a vendor were implemented with bug 5347. -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@biblibre.co | |m AssignedTo|claire.hernandez@biblibre.c |jonathan.druart@biblibre.co |om |m -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |7293 -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |ASSIGNED -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Bug 7291 depends on bug 7293, which changed state. Bug 7293 Summary: new fields in vendor table http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7293 What |Old Value |New Value ---------------------------------------------------------------------------- Status|NEW |RESOLVED Resolution| |DUPLICATE --- Comment #2 from Jonathan Druart <jonathan.druart@biblibre.com> 2012-02-13 14:43:51 UTC --- *** Bug 7293 has been marked as a duplicate of this bug. *** -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 --- Comment #3 from Jonathan Druart <jonathan.druart@biblibre.com> 2012-02-13 14:46:30 UTC --- Created attachment 7622 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=7622 Bug 7291: Adds new field aqbooksellers.deliverytime Bug 7291: Adds new field aqbooksellers.deliverytime New field deliverytime in aqbooksellers table. It is an estimated delivery time for orders (in days). You can set this delay on the supplier modification page. It is used in the late orders search. The order estimated date is the aqbasket.closedate + aqbooksellers.deliverytime If you set a delay, the query check if closedate <= today - delay If you set a "delivery time from" and a "delivery time to", the query check if $delivery_time_from <= aqbooksellers.deliverytime is not NULL and if closedate + deliverytime >= $delivery_time_to if there is not a time_to then $delivery_time_to = the current date. -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Patch doesn't apply CC| |katrin.fischer@bsz-bw.de --- Comment #4 from Katrin Fischer <katrin.fischer@bsz-bw.de> 2012-02-22 06:03:11 UTC --- Hi Jonathan, I am sorry, this patch has a lot of conflicts now and will no longer apply. Could you please rebase and resubmit? Perhaps you will also want to make use of the TT plugin for dates. -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #7622|0 |1 is obsolete| | --- Comment #5 from Jonathan Druart <jonathan.druart@biblibre.com> 2012-02-22 09:32:40 UTC --- Created attachment 7800 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=7800 Bug 7291: Adds new field aqbooksellers.deliverytime Rebased patch -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #7800|0 |1 is obsolete| | --- Comment #6 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 8074 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=8074&action=edit Rebased patch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #8074|Rebased patch |Bug 7291: Adds new field description| |aqbooksellers.deliverytime --- Comment #7 from Jonathan Druart <jonathan.druart@biblibre.com> --- Comment on attachment 8074 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=8074 Bug 7291: Adds new field aqbooksellers.deliverytime Rebased patch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Patch doesn't apply |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Corinne BULAC <corinnebulac@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA CC| |corinnebulac@gmail.com --- Comment #8 from Corinne BULAC <corinnebulac@gmail.com> --- the filter on "Estimated Delivery date from: "/"to" doesnt't work Vendor -> OK Days ago -> OK -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #8074|0 |1 is obsolete| | --- Comment #9 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 8310 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=8310&action=edit Bug 7291: Adds new field aqbooksellers.deliverytime Date to iso -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 --- Comment #10 from Koha Team Lyon 3 <koha@univ-lyon3.fr> --- Created attachment 8332 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=8332&action=edit csv file -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Koha Team Lyon 3 <koha@univ-lyon3.fr> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #8332|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Corinne BULAC <corinnebulac@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA --- Comment #11 from Corinne BULAC <corinnebulac@gmail.com> --- this is still a problem. We have write delivery date as "AAAAMMJJ' if we want if it to work. Or the input form indicate "JJ/AA/MMMM' (ditto for the calendar help) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff --- Comment #12 from Jonathan Druart <jonathan.druart@biblibre.com> --- I test on a sandbox and I can not reproduce the problem. Please, can you retest and tell me yours differents actions ? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Corinne BULAC <corinnebulac@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off --- Comment #13 from Corinne BULAC <corinnebulac@gmail.com> --- New tests -> OK -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Paul Poulain <paul.poulain@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA CC| |paul.poulain@biblibre.com --- Comment #14 from Paul Poulain <paul.poulain@biblibre.com> --- QA comment: * patch does not apply, there are small merge problem * dates are formatted without the Date plugin, please fix ! + estimateddeliverydate => C4::Dates->new( $estimateddeliverydate, 'iso' )->output, * you use a MYSQLism for getting the current date. Instead of CURDATE( ) use CAST(now() AS date) Marking failed QA. The rest is OK, will mark passed QA once you've fixed those points -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #8310|0 |1 is obsolete| | --- Comment #15 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 8592 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=8592&action=edit Bug 7291: Adds new field aqbooksellers.deliverytime Rebased patch. Remove warnings in tt file. Replace MYSQLism with standard format Replace date format -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Paul Poulain <paul.poulain@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 --- Comment #16 from Paul Poulain <paul.poulain@biblibre.com> --- QA comment: 1- there is a hardcoded variable inside SQL: - WHERE (closedate < DATE_SUB(CURDATE( ),INTERVAL $delay DAY) that is removed => +1 from QA point of view ! 2- the dates are displayed using kohaDates plugin => +1 A possible enhancement would be to highlight passed dates, but outside from a QA proposing passed QA, (not setting it as it's a BibLibre patch) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA CC| |m.de.rooy@rijksmuseum.nl --- Comment #17 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- Additional QA comment: I have no real objections for pushing this patch, but want to note: 1) Use of adddate, date_sub, ifnull: they are all mysql-isms I suspect that you could not avoid them here; and they are already present too. But what is the use of replacing curdate's and backquotes if we do not remove typical mysql date/time functions? But this is a discussion on itself, and should be held elsewhere. 2) BTW You add backtics in kohastructure with this patch (instead of removing them..) 3) Very small note: You edited the part with the cryptic test: not $delay =~ /^\d{1,3}$/ Actually, we do not want a delay>999 (for some reason). If you edit that line, please make the test faster and more readable with delay>999. Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|koha.sekjal@gmail.com |m.de.rooy@rijksmuseum.nl -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 --- Comment #18 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 8809 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=8809&action=edit Bug 7291: Followup: removes backquotes Hi Marcel, Thanks for your comment. 1,2/ This followup removes backquotes in kohastructure. I would like to remove these mysql specific functions, but there is not yet a way to do this in koha. 3/ the regexp does the same think as 999, even better because it does not warn if $delay is not an integer. I thing it is better, don't you think ? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Paul Poulain <paul.poulain@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #19 from Paul Poulain <paul.poulain@biblibre.com> --- (In reply to comment #18)
Created attachment 8809 [details] Bug 7291: Followup: removes backquotes
3/ the regexp does the same think as 999, even better because it does not warn if $delay is not an integer. I thing it is better, don't you think ?
I agree, as it avoid a risk of a SQL injection. patch pushed -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7291 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |10556 -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org