[Bug 31357] New: Separate holds history from intranetreadinghistory
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Bug ID: 31357 Summary: Separate holds history from intranetreadinghistory Change sponsored?: --- Product: Koha Version: 21.11 Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Patrons Assignee: koha-bugs@lists.koha-community.org Reporter: bwsdonna@gmail.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com, kyle.m.hall@gmail.com Currently the system preference intranetreadinghistory determines visibility of both circulation history and holds history tabs in the patron record. It would be helpful to allow the option of setting each of those independently. Specifically, libraries have requested the option of being able to view the holds history in a patron record without having to enable viewing of the circulation history. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 --- Comment #1 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 152875 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=152875&action=edit Bug 31357: Separate holds history from intranetreadinghistory Currently the system preference intranetreadinghistory determines visibility of both circulation history and holds history tabs in the patron record. It would be helpful to allow the option of setting each of those independently. Specifically, libraries have requested the option of being able to view the holds history in a patron record without having to enable viewing of the circulation history. Test Plan: 1) Apply this patch 2) Restart all the things! 3) Run updatadatabase.pl 4) Verify the new syspref intranetReadingHistoryHolds has the same value as the existing syspref intranetreadinghistory 5) Disable intranetreadinghistory, enable intranetReadingHistoryHolds 6) Verify you can view a patron's holds history but not reading history -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Sam Lau <samalau@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Sam Lau <samalau@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #152875|0 |1 is obsolete| | --- Comment #2 from Sam Lau <samalau@gmail.com> --- Created attachment 152877 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=152877&action=edit Bug 31357: Separate holds history from intranetreadinghistory Currently the system preference intranetreadinghistory determines visibility of both circulation history and holds history tabs in the patron record. It would be helpful to allow the option of setting each of those independently. Specifically, libraries have requested the option of being able to view the holds history in a patron record without having to enable viewing of the circulation history. Test Plan: 1) Apply this patch 2) Restart all the things! 3) Run updatadatabase.pl 4) Verify the new syspref intranetReadingHistoryHolds has the same value as the existing syspref intranetreadinghistory 5) Disable intranetreadinghistory, enable intranetReadingHistoryHolds 6) Verify you can view a patron's holds history but not reading history Signed-off-by: Sam Lau <samalau@gmail.com> -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |kyle@bywatersolutions.com |ity.org | -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |nick@bywatersolutions.com Version|21.11 |master -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #152877|0 |1 is obsolete| | --- Comment #3 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 156547 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=156547&action=edit Bug 31357: Separate holds history from intranetreadinghistory Currently the system preference intranetreadinghistory determines visibility of both circulation history and holds history tabs in the patron record. It would be helpful to allow the option of setting each of those independently. Specifically, libraries have requested the option of being able to view the holds history in a patron record without having to enable viewing of the circulation history. Test Plan: 1) Apply this patch 2) Restart all the things! 3) Run updatadatabase.pl 4) Verify the new syspref intranetReadingHistoryHolds has the same value as the existing syspref intranetreadinghistory 5) Disable intranetreadinghistory, enable intranetReadingHistoryHolds 6) Verify you can view a patron's holds history but not reading history Signed-off-by: Sam Lau <samalau@gmail.com> JD amended patch: * renamed syspref intranetReadingHistoryHolds => IntranetReadingHistoryHolds * tidy -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart+koha@gmail. | |com --- Comment #4 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Kyle, I have renamed the pref to make it start with an uppercase. Hope you agree with that (otherwise say it and I will resubmit). It seems more inline with what we have already. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 --- Comment #5 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- It would be nice to rename intranetreadinghistory with IntranetReadingHistory for the same release. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 --- Comment #6 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to Jonathan Druart from comment #4)
Kyle, I have renamed the pref to make it start with an uppercase. Hope you agree with that (otherwise say it and I will resubmit). It seems more inline with what we have already.
A bit belated, but yes, I have no problem with that! Many hands make light work! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)| |23.11.00 released in| | Status|Passed QA |Pushed to master -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 --- Comment #7 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Pushed to master for 23.11. Nice work everyone, thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |FIXED Keywords| |release-notes-needed Status|Pushed to master |RESOLVED CC| |fridolin.somers@biblibre.co | |m --- Comment #8 from Fridolin Somers <fridolin.somers@biblibre.com> --- Enhancement not pushed to 23.05.x -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|RESOLVED |Needs documenting Resolution|FIXED |--- -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |35183 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35183 [Bug 35183] Rename intranetreadinghistory to IntranetReadingHistory -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 --- Comment #9 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Jonathan Druart from comment #5)
It would be nice to rename intranetreadinghistory with IntranetReadingHistory for the same release.
Filed as: Bug 35183 - Rename [opac|intranet]readinghistory to [Opac/Intranet]ReadingHistory Turns out not quite as easy as we also should take care of opacreadinghistory at the same time. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31357 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|release-notes-needed | Status|Needs documenting |RESOLVED Documentation| |https://gitlab.com/koha-com submission| |munity/koha-manual/-/merge_ | |requests/916 CC| |caroline.cyr-la-rose@inlibr | |o.com Documentation| |Caroline Cyr La Rose contact| | Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org