[Bug 8367] How long is a hold waiting for pickup at a more granular level
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8367 --- Comment #160 from David Cook <dcook@prosentient.com.au> --- Comment on attachment 118021 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=118021 Bug 8367: Add holds_pickup_period circulation rule Review of attachment 118021: --> (https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=8367&attachment=118021) ----------------------------------------------------------------- ::: koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-reserve.tt @@ +272,5 @@
</ul>
+ [% IF pickup_delays %] + <p id="pickup_delay" style="display:none;">When your item is ready for pickup, you will have <span id="pickup_delay_days"></span> days to pick it up from this library.</p> + [% END %]
This doesn't display for any bibs but the first one if you have multiple bibs to place holds on. @@ +490,5 @@
+ var selected_branch = $("#branch_1").val(); + [% FOREACH branchcode IN pickup_delays.keys %] + var branchcode = "[% branchcode | html %]"; + if ( branchcode == selected_branch ) { + $("#pickup_delay_days").text([% pickup_delays.$branchcode | html %]);
#pickup_delay_days can't work because it's not biblio-specific, so this will break if you're placing holds on more than 1 bib at a time. @@ +499,4 @@
$(document).ready(function() { + calculate_delay_days(); + $("#pickup_delay").show(); + $("#branch_1").change(function(){
This has the same selector problem because it's hard-coded to biblionumber 1. ::: opac/opac-reserve.pl @@ +694,5 @@
+ }); + $hold_pickup_delay_by_branch{$branch->branchcode} = $rule->rule_value if ( $rule and $rule->rule_value ); +} + +$template->param( pickup_delays => \%hold_pickup_delay_by_branch );
"pickup_delays" is a confusing name, and it looks like there's no consideration of ReservesMaxPickUpDelay here, even though Hold.pm seems to take it into consideration... which could lead to confusing displays. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org