[Bug 12353] New: Patrons need to know the last pickup date for reserves
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Bug ID: 12353 Summary: Patrons need to know the last pickup date for reserves Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: OPAC Assignee: oleonard@myacpl.org Reporter: pasi.kallinen@pttk.fi QA Contact: testopia@bugs.koha-community.org OPAC does not show the date before which the patron must come and get their reserved book. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Christopher Brannon <cbrannon@cdalibrary.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |cbrannon@cdalibrary.org --- Comment #1 from Christopher Brannon <cbrannon@cdalibrary.org> --- Would like to see this date on the staff side too. Christopher -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |olli-antti.kivilahti@jns.fi Summary|Patrons need to know the |Everybody need to know the |last pickup date for |last pickup date for |reserves |reserves -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|oleonard@myacpl.org |olli-antti.kivilahti@jns.fi -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Everybody need to know the |Everybody need to know the |last pickup date for |last pickup date for |reserves |reserves, even notices. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #2 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- Created attachment 31556 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=31556&action=edit Initial commitmonster When calculating the last date before reserve expires, skip all days marked as holidays. This is done in C4::Reserves::_reserve_last_pickup_date() and Koha::Reserves::GetLastpickupdate() Also cronjobs/holds/delete_expired_holds.pl and circ/waitingreserves.pl are modified to use these routines, instead of each using their own method of determining last pickup date. Add a new <<lastpickupdate>> marker usable in RESERVESLIP and HOLD. Display the last pickup date in member/moremember.pl and circ/circulation.pl and circ/waitingreserves.pl opac/opac-user.pl -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #3 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- Refactored paxed's and seppalaj's work to work with 3.16.3. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Everybody need to know the |Reserves last pickup date |last pickup date for |needs to respect holidays, |reserves, even notices. |and everybody need to know | |the last pickup date for | |reserves, even notices. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff --- Comment #4 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- I hope you sign this off Christopher! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Version|master |3.16 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de See Also| |http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=8735 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #31556|0 |1 is obsolete| | --- Comment #5 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- Created attachment 31572 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=31572&action=edit Bug-12353-Everybody-needs-to-know-the-last-pickup-da.patch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |12917 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #6 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- Created attachment 31584 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=31584&action=edit Bug 12353 - Last pickup date in the letter templates Bug 12353 - Last pickup date in the letter templates TEST PLAN: PREPARE THE LETTER: 1. Go to Home › Tools › Notices & Slips. 2. Edit letter template with code HOLD. 3. Add the <<lastpickupdate>> placeholder to different template types. SEND AND RECEIVE THE LETTER: 1. Create a reservation for a Borrower with pickup branch. 2. Make sure the borrower receives "Hold waiting for pickup"-notices using the message _transport_Type on which you added the <<lastpickupdate>> -placeholder. 3. Check-in the corresponding Item in the pickup branch and confirm the hold for the Borrower 4. Wait for the message to be delivered and observe your <<lastpickupdate>> being replaced with a date. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #7 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- Created attachment 31585 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=31585&action=edit Bug 12353 - Displaying the last pickup date in OPAC and staff client and waitingholds.pl Bug 12353 - Displaying the last pickup date in OPAC and staff client and waitingholds.pl TEST PLAN: 1. Create a reservation for a Borrower with pickup branch 2. Check-in the corresponding Item in the pickup branch and confirm the hold for the Borrower 3. Go to circ/circulation.pl for the Borrower and verify that the reservation is "Waiting for pickup" 4. In the Home › Circulation › Checkouts -tab (circ/circulation.pl) and in the Home › Patrons › Patron details -tab and in the OPAC your summary and in the circ/waitingreserves.pl When looking at reserves, you will find a last pickup date -column added which has a value if the reservation is waiting for pickup. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #31572|0 |1 is obsolete| | --- Comment #8 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- Created attachment 31586 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=31586&action=edit Bug 12353 - cancel_expired_holds.pl -cronjob respects last pickup date Bug 12353 - cancel_expired_holds.pl -cronjob respects last pickup date -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #9 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- Make sure to test with unicode material! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |tomascohen@gmail.com --- Comment #10 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Please, make sure the functinality changes you introduce get proper unit tests. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Patch doesn't apply --- Comment #11 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Hi Olli-Antti, a few things that have me confused here: 1) Can you please explain how your patches are different to bug 8735? I think we can't have different solutions on master and in 3.16 - this would not make much sense. :) 2) Please only send patches against master, if it's not a problem that only appears in a lower version. Patches don't apply. 3) I think this is somewhere in a grey zone, but more an enh than a bugfix, so should not be for 3.16, but for 3.18. The new placeholder is more like a 'small new feature' than a bugfix. 4) Some of the last pickup dates in the templates use the TT Dates plugin, others don't. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #12 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- Thanks for the review Katrin! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #13 from Christopher Brannon <cbrannon@cdalibrary.org> --- Olli-Antti, I did not get notified of your patch. I will take a look at it when you address the things already in question. Christopher -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #14 from Christopher Brannon <cbrannon@cdalibrary.org> --- (In reply to Katrin Fischer from comment #11)
Hi Olli-Antti,
a few things that have me confused here:
1) Can you please explain how your patches are different to bug 8735?
Katrin, I don't think this has anything to do with 8735. 8735 addresses the expired date falling on holidays. Was there a different bug you meant to refer to? Christopher -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #15 from Christopher Brannon <cbrannon@cdalibrary.org> --- (In reply to Christopher Brannon from comment #14)
(In reply to Katrin Fischer from comment #11)
Hi Olli-Antti,
a few things that have me confused here:
1) Can you please explain how your patches are different to bug 8735?
Katrin, I don't think this has anything to do with 8735. 8735 addresses the expired date falling on holidays. Was there a different bug you meant to refer to?
Christopher
Katrin, Ignore me. Didn't see the holidays modifications. :/ I've been off for 4 days. Can you tell? Christopher -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #16 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- 4 days are forever in terms of Koha :) Hope you had a good time! I was not sure how it all fits together, hoping that Olli can explain. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Patch doesn't apply |In Discussion --- Comment #17 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- I didn't know of Bug 8735 when I refactored others work and shared this featureset we have. I think that bug is very similar, except this bug introduces more stuff. Do as you please with this, maybe it helps someone else who is looking for the same features to use this code. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #18 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- As an important difference this feature removes code duplication regarding holds expiration from 3 different places and centralizes it to actual functions. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 --- Comment #19 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I was about to file a bug for the holds calculated expiration date not caring about the calendar (calculate ReservesMaxPickUpDelay in opening days vs. calendar days), but will leave a not here instead. This bug seems to have a wider scope tho. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Tom Misilo <misilot@fit.edu> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |misilot@fit.edu -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Christopher Davis <mr.cataloger@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |mr.cataloger@gmail.com -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12353 Heather Braum <hbraum@nekls.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |hbraum@nekls.org -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org