[Bug 11879] Add a new borrower field : main contact method.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11879 --- Comment #103 from Charles Farmer <charles.farmer@inlibro.com> --- Much tighter patches this time, thanks to Mark's comments. I'll review the changes one by one: 1) members/moremember.pl was adapted to reduce the diff's length. In previous iterations, many additional variables were passed to the templates -- borrowernumber, othernames, etc. -- but these are not necessary anymore, thanks to the patron objects. The template moremember-brief.tt was adapted to reflect these changes. 2) borrowers_primary_contact_method.sql is now adding columns at the very end of the table, in order to keep the existing columns in the same order. 3) `lastseen` had no reason whatsoever to be here. Kept the field the way it already was in the tables where we added primary_contact_method. 4) whitespace changes were rolled back, according to the minimum diff policy(TM) 5) I'm definitely responsible for the moremember.tt screwup code duplication; it appeared in patch #69028 when I must've rebased. It's now removed from this patch. 6) Indentation was corrected in opac-memberentry.pl This code should also pass qa -c 4. Needs signoff. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org