[Bug 38016] New: Relabel booking precaution column heading in circulation rules tables
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Bug ID: 38016 Summary: Relabel booking precaution column heading in circulation rules tables Change sponsored?: --- Product: Koha Version: Main Hardware: All OS: All Status: NEW Severity: trivial Priority: P5 - low Component: Circulation Assignee: koha-bugs@lists.koha-community.org Reporter: katrin.fischer@bsz-bw.de QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com, kyle.m.hall@gmail.com Depends on: 34440 In the circulation rules there are 2 tables with 2 new columns named: * booking preparation period * booking precaution period While the first is before the booking, the second is after the booking is returned, but that's not clearly reflected in the name. Some alternative suggestions we came up with: A) * booking lead period * booking trail period B) * booking warm-up period * booking cool-down period C) * booking pre-buffer (days) * booking post-buffer (days) Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34440 [Bug 34440] Add warm-up and cool-down periods to bookings -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Ed Veal <eveal@mckinneytexas.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |eveal@mckinneytexas.org -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 davedaghita <ddaghita@mckinneytexas.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |ddaghita@mckinneytexas.org -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 George Williams (NEKLS) <george@nekls.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |george@nekls.org --- Comment #1 from George Williams (NEKLS) <george@nekls.org> --- How about: D) * booking pre-processing * booking post-processing -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Aleisha Amohia <aleisha@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |aleisha@catalyst.net.nz --- Comment #2 from Aleisha Amohia <aleisha@catalyst.net.nz> --- Also E) * pre-booking buffer (days) * post-booking buffer (days) -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Heather Rommens <heather@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |heather@bywatersolutions.co | |m --- Comment #3 from Heather Rommens <heather@bywatersolutions.com> --- I agree that this relabeling is needed. How about something like: *Booking preparation period *Booking recovery period -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 --- Comment #4 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Heather Rommens from comment #3)
I agree that this relabeling is needed. How about something like: *Booking preparation period *Booking recovery period
We are naming this option F :) -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |caroline.cyr-la-rose@inlibr | |o.com --- Comment #5 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- (In reply to George Williams (NEKLS) from comment #1)
How about:
D) * booking pre-processing * booking post-processing
I like this the best, maybe with a slight variation D.a) * pre-booking processing * post-booking processing But I'd be fine with D) as is -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Marie-Luce Laflamme <marie-luce.laflamme@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |marie-luce.laflamme@inlibro | |.com --- Comment #6 from Marie-Luce Laflamme <marie-luce.laflamme@inlibro.com> --- (In reply to George Williams (NEKLS) from comment #1)
How about:
D) * booking pre-processing * booking post-processing
I prefer this version, as it seems clearer to a non-native English speaker. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Aleisha Amohia <aleisha@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |aleisha@catalyst.net.nz |ity.org | Change sponsored?|--- |Sponsored Status|NEW |ASSIGNED -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Aleisha Amohia <aleisha@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff Patch complexity|--- |String patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 --- Comment #7 from Aleisha Amohia <aleisha@catalyst.net.nz> --- Created attachment 172119 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=172119&action=edit Bug 38016: Rename booking circulation rules This enhancement renames the bookings circulation rules to better describe what they do. To test: 1. Go to Koha Administration -> Circulation and fines rules 2. Scroll to the 'Default holds and bookings policies by item type' section 3. Notice the bookings rules in this table: - Booking preparation period - Booking precaution period 4. Apply the patch and refresh the page 5. Confirm the bookings have been renamed to: - Booking pre-processing (days) - Booking post-processing (days) 6. Confirm these names make sense and it is clear what the rules are used for and how they are applied 7. Put values in the input fields for these rules and confirm saving a rule works as expected Sponsored-by: Catalyst IT -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #172119|0 |1 is obsolete| | --- Comment #8 from David Nind <david@davidnind.com> --- Created attachment 172182 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=172182&action=edit Bug 38016: Rename booking circulation rules This enhancement renames the bookings circulation rules to better describe what they do. To test: 1. Go to Koha Administration -> Circulation and fines rules 2. Scroll to the 'Default holds and bookings policies by item type' section 3. Notice the bookings rules in this table: - Booking preparation period - Booking precaution period 4. Apply the patch and refresh the page 5. Confirm the bookings have been renamed to: - Booking pre-processing (days) - Booking post-processing (days) 6. Confirm these names make sense and it is clear what the rules are used for and how they are applied 7. Put values in the input fields for these rules and confirm saving a rule works as expected Sponsored-by: Catalyst IT Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Kyle M Hall (khall) <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |kyle@bywatersolutions.com |y.org | CC| |kyle@bywatersolutions.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Kyle M Hall (khall) <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Kyle M Hall (khall) <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #172182|0 |1 is obsolete| | --- Comment #9 from Kyle M Hall (khall) <kyle@bywatersolutions.com> --- Created attachment 172184 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=172184&action=edit Bug 38016: Rename booking circulation rules This enhancement renames the bookings circulation rules to better describe what they do. To test: 1. Go to Koha Administration -> Circulation and fines rules 2. Scroll to the 'Default holds and bookings policies by item type' section 3. Notice the bookings rules in this table: - Booking preparation period - Booking precaution period 4. Apply the patch and refresh the page 5. Confirm the bookings have been renamed to: - Booking pre-processing (days) - Booking post-processing (days) 6. Confirm these names make sense and it is clear what the rules are used for and how they are applied 7. Put values in the input fields for these rules and confirm saving a rule works as expected Sponsored-by: Catalyst IT Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com --- Comment #10 from Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> --- (In reply to Heather Rommens from comment #3)
I agree that this relabeling is needed. How about something like: *Booking preparation period *Booking recovery period
I personally like this one the best as it's how I saw them functioning in real life.. i.e 'preparation' is time it takes for library to 'do stuff'.. i.e transfers, checking for defects etc etc, whilst 'recovery' is the extra time added to the loan to make sure the item is returned in suitable time.. it's a buffer for the patron being a bit late. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |kkrueger@cuyahogalibrary.or | |g -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 --- Comment #11 from Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> --- I'd like Kristi or someone else from Cuyahoga to weight in as they're about to actively use the feature so understood the original requirements best. I'm not actively against any changes.. just want to make sure they're descriptive in their intended use. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 --- Comment #12 from Kristi <kkrueger@cuyahogalibrary.org> --- I'll check around here this morning. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 --- Comment #13 from Kristi <kkrueger@cuyahogalibrary.org> --- Checked with others at CCPL. We agree that the option selected (- Booking pre-processing (days) - Booking post-processing (days)) is clear and works for our needs. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 --- Comment #14 from Aleisha Amohia <aleisha@catalyst.net.nz> --- (In reply to Kristi from comment #13)
Checked with others at CCPL. We agree that the option selected (- Booking pre-processing (days) - Booking post-processing (days)) is clear and works for our needs.
Thanks Kristi and Martin - really helpful to get your feedback! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 --- Comment #15 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- It was fun to work on that with you all at the Kohacon24 hackfest! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)| |24.11.00 released in| | Status|Passed QA |Pushed to main -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 --- Comment #16 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Pushed for 24.11! Well done everyone, thank you! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 --- Comment #17 from Aleisha Amohia <aleisha@catalyst.net.nz> --- Woohoo team effort! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Lucas Gass (lukeg) <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to main |RESOLVED Resolution|--- |FIXED CC| |lucas@bywatersolutions.com --- Comment #18 from Lucas Gass (lukeg) <lucas@bywatersolutions.com> --- Missing 24.05.x deps, no backport. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38016 Bug 38016 depends on bug 34440, which changed state. Bug 34440 Summary: Add warm-up and cool-down periods to bookings https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34440 What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org