[Bug 29001] New: Subfields attributes are not preserved when order is changed in framework
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Bug ID: 29001 Summary: Subfields attributes are not preserved when order is changed in framework Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: minor Priority: P5 - low Component: MARC Bibliographic data support Assignee: koha-bugs@lists.koha-community.org Reporter: mathsabypro@gmail.com QA Contact: testopia@bugs.koha-community.org Bug 8976 adds the ability to change the default order of the subfields in MARC framework. But it does not preserve the Repeatable or Mandatory attribute. To test : in a MARC framework, define a subfield as Mandatory. Move the subfield to an other position within the field. The Mandatory flag for that subfield is not preserved. Instead, the subfield occupying the same position is flaged as Mandatory. M. Saby -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |7882 Severity|minor |normal --- Comment #1 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I can replicate the issue. To test: - Edit subfields of any field - Mark the last subfield in the row as mandatory - Save - Edit again and verify the field shows as mandatory - Move the field to the first position and save - Verify the original field is no longer mandatory, but the last subfield is now Updating severity as this is a data issue. Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7882 [Bug 7882] Add ability to move and reorder fields and subfields in MARC editor -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 --- Comment #2 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 137874 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=137874&action=edit Bug 29001: Fix framework edition when subfields are reordered There is a flaw when subfields are ordered, the inputs are not retrieved correctly. We should not rely on the order but use an id instead. Test plan: Create, edit subfields Modify values from the different subfields Confirm that values are correctly saved -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on|7882 |8976 CC| |jonathan.druart+koha@gmail. | |com Assignee|koha-bugs@lists.koha-commun |jonathan.druart+koha@gmail. |ity.org |com Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7882 [Bug 7882] Add ability to move and reorder fields and subfields in MARC editor https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8976 [Bug 8976] Default sequence of subfields in cataloguing and item editor -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Thibault Keromnès <thibault.keromnes@univ-paris8.fr> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |thibault.keromnes@univ-pari | |s8.fr Status|Needs Signoff |Failed QA --- Comment #3 from Thibault Keromnès <thibault.keromnes@univ-paris8.fr> --- The patch fixes the issue but brings another one, I can't mark a subfield as repeatable now (if i check the 3 attributes and save the subfield will be mandatory and important but not repeatable). I don't have this issue with the current master. I change the status to failed QA, not sure it's the right one, feel free to change it. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #137874|0 |1 is obsolete| | --- Comment #4 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 137893 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=137893&action=edit Bug 29001: Fix framework edition when subfields are reordered There is a flaw when subfields are ordered, the inputs are not retrieved correctly. We should not rely on the order but use an id instead. Test plan: Create, edit subfields Modify values from the different subfields Confirm that values are correctly saved -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 --- Comment #5 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- (In reply to Thibault Keromnès from comment #3)
The patch fixes the issue but brings another one, I can't mark a subfield as repeatable now (if i check the 3 attributes and save the subfield will be mandatory and important but not repeatable). I don't have this issue with the current master.
I change the status to failed QA, not sure it's the right one, feel free to change it.
Indeed, thanks! Should be fixed now. Yes, Failed QA is the correct status when the patch does not work as expected. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 sandboxes@biblibre.com <sandboxes@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #137893|0 |1 is obsolete| | --- Comment #6 from sandboxes@biblibre.com <sandboxes@biblibre.com> --- Created attachment 137904 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=137904&action=edit Bug 29001: Fix framework edition when subfields are reordered There is a flaw when subfields are ordered, the inputs are not retrieved correctly. We should not rely on the order but use an id instead. Test plan: Create, edit subfields Modify values from the different subfields Confirm that values are correctly saved Signed-off-by: Thibault Kero <thibault.keromnes@univ-paris8.fr> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Thibault Keromnès <thibault.keromnes@univ-paris8.fr> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Joonas Kylmälä <joonas.kylmala@iki.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |joonas.kylmala@iki.fi QA Contact|testopia@bugs.koha-communit |joonas.kylmala@iki.fi |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Joonas Kylmälä <joonas.kylmala@iki.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Joonas Kylmälä <joonas.kylmala@iki.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #137904|0 |1 is obsolete| | --- Comment #7 from Joonas Kylmälä <joonas.kylmala@iki.fi> --- Created attachment 137991 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=137991&action=edit Bug 29001: Fix framework edition when subfields are reordered There is a flaw when subfields are ordered, the inputs are not retrieved correctly. We should not rely on the order but use an id instead. Test plan: Create, edit subfields Modify values from the different subfields Confirm that values are correctly saved Signed-off-by: Thibault Kero <thibault.keromnes@univ-paris8.fr> Signed-off-by: Joonas Kylmälä <joonas.kylmala@iki.fi> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 --- Comment #8 from Joonas Kylmälä <joonas.kylmala@iki.fi> --- Created attachment 137992 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=137992&action=edit Bug 29001: (QA follow-up) Remove code duplication Signed-off-by: Joonas Kylmälä <joonas.kylmala@iki.fi> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |22.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 --- Comment #9 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Pushed to master for 22.11. Nice work everyone, thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)|22.11.00 |22.11.00, 22.05.05 released in| | Status|Pushed to master |Pushed to stable CC| |lucas@bywatersolutions.com --- Comment #10 from Lucas Gass <lucas@bywatersolutions.com> --- Backported to 22.05.x for 22.05.05 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Arthur Suzuki <arthur.suzuki@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |arthur.suzuki@biblibre.com Severity|normal |blocker --- Comment #11 from Arthur Suzuki <arthur.suzuki@biblibre.com> --- lots of conflicts on the templates when trying to apply to 21.11.x. Please provide a backport patch if needed. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Andrew Nugged <nugged@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |nugged@gmail.com --- Comment #12 from Andrew Nugged <nugged@gmail.com> --- (In reply to Lucas Gass from comment #10)
Backported to 22.05.x for 22.05.05
Bug 31238 is also needed in 22.05 because this 29001 brings a bug and fixed in this way: - my $authorised_value = $input->param("authorised_values_$id"); + my $authorised_value = $input->param("authorised_value_$id"); in 31238. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |31238 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31238 [Bug 31238] Unable to save authorised value to frameworks subfields -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29001 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |31869 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31869 [Bug 31869] Unable to save thesaurus value to frameworks subfields -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org