[Bug 28318] New: accounlintes.credit_number missing on the API
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28318 Bug ID: 28318 Summary: accounlintes.credit_number missing on the API Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: REST API Assignee: koha-bugs@lists.koha-community.org Reporter: tomascohen@gmail.com It was added to the DB structure, but bug 28272 skipped it so we could ponder if it is required on the API object and how should we name it. Feels like 'credit_sequence_number' could be a good name for it. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28318 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |martin.renvoize@ptfs-europe |ity.org |.com Status|NEW |ASSIGNED --- Comment #1 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Work to be done: - Assing a field name mapping in Koha::Account::Line->to_api_mapping - Add to the spec The reason I didn't just propose to add it, is because it seems that credits are the only ones that should include it (maybe the same for cash_register_id?) and it then involves overloading Koha::Account::Line->to_api -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28318 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |28272, 19036 --- Comment #2 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Work to be done: - Assing a field name mapping in Koha::Account::Line->to_api_mapping - Add to the spec The reason I didn't just propose to add it, is because it seems that credits are the only ones that should include it (maybe the same for cash_register_id?) and it then involves overloading Koha::Account::Line->to_api Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19036 [Bug 19036] Number payment receipts / payment slips https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28272 [Bug 28272] Definition files are missing additionalProperties: false -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28318 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |14825 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14825 [Bug 14825] Accounts Rewrite Omnibus -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28318 Bug 28318 depends on bug 19036, which changed state. Bug 19036 Summary: Number payment receipts / payment slips https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19036 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28318 Andreas Roussos <a.roussos@dataly.gr> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|accounlintes.credit_number |accountlines.credit_number |missing on the API |missing on the API -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org