[Bug 33809] New: Accessibility: OPAC results page needs more descriptive links
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Bug ID: 33809 Summary: Accessibility: OPAC results page needs more descriptive links Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: OPAC Assignee: oleonard@myacpl.org Reporter: matt.blenkinsop@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org A report by the Shaw trust for the British Museum's installation of Koha has identified some links in the OPAC results that are not descriptive enough for screen reader users. Extract below: "The text of a link should describe the destination of the link and the link’s purpose. Providing a descriptive link text will allow users to easily determine the function of the link and make educated decisions to click the link or not. If it is not possible to identify the purpose of the link from the link text itself, then this information should be provided in context. Screen reader users have the ability to display and navigate by lists of elements, or jump from element to element. Navigating this way is much quicker than listening to a whole page, however the context provided by paragraphs and other narrative is lost and non-descriptive links become harder to understand. For downloadable links, we recommend that the file type and size of the file is also included in the link text to allow the user to make a decision whether or not to download the file." This bug addresses the links identified in the report as needing clearer descriptions. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #1 from Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> --- Created attachment 151568 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151568&action=edit Bug 33809: Facet "Show more/less" links don't identify what they are showing This patch addresses the Show more/less links in the side menu in opac-facets.inc. The links don't identify which facet they are linked to and this is confusing for screen readers. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #2 from Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> --- Created attachment 151569 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151569&action=edit Bug 33809: Place hold and Add to cart links need better descriptions The place hold and add to cart buttons should identify to screen readers which title the button is linked to. This patch adds aria-labels that include the item title to make this more clear -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151569|0 |1 is obsolete| | --- Comment #3 from Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> --- Created attachment 151576 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151576&action=edit Bug 33809: Place hold and Add to cart links need better descriptions The place hold and add to cart buttons should identify to screen readers which title the button is linked to. This patch adds aria-labels that include the item title to make this more clear -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|oleonard@myacpl.org |matt.blenkinsop@ptfs-europe | |.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |lucas@bywatersolutions.com Patch complexity|--- |Small patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151568|0 |1 is obsolete| | --- Comment #4 from Lucas Gass <lucas@bywatersolutions.com> --- Created attachment 151606 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151606&action=edit Bug 33809: Facet "Show more/less" links don't identify what they are showing This patch addresses the Show more/less links in the side menu in opac-facets.inc. The links don't identify which facet they are linked to and this is confusing for screen readers. Signed-off-by: Lucas Gass <lucas@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151576|0 |1 is obsolete| | --- Comment #5 from Lucas Gass <lucas@bywatersolutions.com> --- Created attachment 151607 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151607&action=edit Bug 33809: Place hold and Add to cart links need better descriptions The place hold and add to cart buttons should identify to screen readers which title the button is linked to. This patch adds aria-labels that include the item title to make this more clear Signed-off-by: Lucas Gass <lucas@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #6 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 151925 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151925&action=edit Bug 33809: (follow-up) Grammar correction This is somewhat nitpicky but I think "Show fewer..." is more correct than "Show less..." for strings like "Show fewer authors." 'Generally, fewer is used when the number of things is counted ("fewer problems") whereas less is used when the number is measured ("less trouble" or "less time").' -- https://www.merriam-webster.com/words-at-play/fewer-vs-less It's not a strict rule but to my ear it sounds more correct. The brief "Show less" displayed on screen seems fine because the object feels indeterminate: "Show less information." -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Ray Delahunty <r.delahunty@arts.ac.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |r.delahunty@arts.ac.uk -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #7 from Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> --- Ahh I originally put "Show fewer..." in those strings but changed it as I thought it might get rejected for consistency with the "Show less" link. Completely agree with "Show fewer...", should've taken the gamble when I uploaded the patch! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151925|0 |1 is obsolete| | --- Comment #8 from Lucas Gass <lucas@bywatersolutions.com> --- Created attachment 152050 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=152050&action=edit Bug 33809: (follow-up) Grammar correction This is somewhat nitpicky but I think "Show fewer..." is more correct than "Show less..." for strings like "Show fewer authors." 'Generally, fewer is used when the number of things is counted ("fewer problems") whereas less is used when the number is measured ("less trouble" or "less time").' -- https://www.merriam-webster.com/words-at-play/fewer-vs-less It's not a strict rule but to my ear it sounds more correct. The brief "Show less" displayed on screen seems fine because the object feels indeterminate: "Show less information." Signed-off-by: Lucas Gass <lucas@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #9 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 153121 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=153121&action=edit Bug 33809: Centralize duplicated code -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA CC| |m.de.rooy@rijksmuseum.nl --- Comment #10 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- I am seeing items.title Please clarify? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #11 from Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> --- Do you mean you are seeing it in the label in the OPAC or just seeing it in the code? I've just checked the patch again and am seeing it correctly in the OPAC. In terms of why it is items (plural) in the code - for each result the title-actions-menu.inc is rendered to produce the action links. It takes a parameter of items and in this case that receives the value of SEARCH_RESULT which is the bib record. I'm not really sure why "items" is used as the parameter when it appears to be passing a bib record - maybe that's something to change in a new bug? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |kyle@bywatersolutions.com QA Contact|testopia@bugs.koha-communit |kyle@bywatersolutions.com |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151606|0 |1 is obsolete| | Attachment #151607|0 |1 is obsolete| | Attachment #152050|0 |1 is obsolete| | Attachment #153121|0 |1 is obsolete| | --- Comment #12 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 157986 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=157986&action=edit Bug 33809: Facet "Show more/less" links don't identify what they are showing This patch addresses the Show more/less links in the side menu in opac-facets.inc. The links don't identify which facet they are linked to and this is confusing for screen readers. Signed-off-by: Lucas Gass <lucas@bywatersolutions.com> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #13 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 157987 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=157987&action=edit Bug 33809: Place hold and Add to cart links need better descriptions The place hold and add to cart buttons should identify to screen readers which title the button is linked to. This patch adds aria-labels that include the item title to make this more clear Signed-off-by: Lucas Gass <lucas@bywatersolutions.com> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #14 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 157988 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=157988&action=edit Bug 33809: (follow-up) Grammar correction This is somewhat nitpicky but I think "Show fewer..." is more correct than "Show less..." for strings like "Show fewer authors." 'Generally, fewer is used when the number of things is counted ("fewer problems") whereas less is used when the number is measured ("less trouble" or "less time").' -- https://www.merriam-webster.com/words-at-play/fewer-vs-less It's not a strict rule but to my ear it sounds more correct. The brief "Show less" displayed on screen seems fine because the object feels indeterminate: "Show less information." Signed-off-by: Lucas Gass <lucas@bywatersolutions.com> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #15 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 157989 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=157989&action=edit Bug 33809: Centralize duplicated code Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)| |23.11.00 released in| | Status|Passed QA |Pushed to master -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 --- Comment #16 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Pushed to master for 23.11. Nice work everyone, thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |fridolin.somers@biblibre.co | |m Status|Pushed to master |Needs documenting --- Comment #17 from Fridolin Somers <fridolin.somers@biblibre.com> --- Enhancement not pushed to 23.05.x -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33809 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |caroline.cyr-la-rose@inlibr | |o.com Status|Needs documenting |RESOLVED Resolution|--- |FIXED --- Comment #18 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- I don't think there's anything to add or change in the manual for this. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org