[Bug 29705] New: Test suite has some IssuingRules left-overs
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Bug ID: 29705 Summary: Test suite has some IssuingRules left-overs Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Test Suite Assignee: chris@bigballofwax.co.nz Reporter: fridolin.somers@biblibre.com QA Contact: testopia@bugs.koha-community.org After Bug 18936, in test suite, there is still t/db_dependent/Koha/IssuingRules.t and t/db_dependent/Koha/IssuingRules/ We should merge with CirculationRules. Also we should rename in : use constant GUESSED_ITEMTYPES_KEY => 'Koha_IssuingRules_last_guess'; -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |18936 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18936 [Bug 18936] Move issuingrules into circulation_rules -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|chris@bigballofwax.co.nz |fridolin.somers@biblibre.co | |m -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff Patch complexity|--- |Small patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 --- Comment #1 from Fridolin Somers <fridolin.somers@biblibre.com> --- Created attachment 128577 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128577&action=edit Bug 29705: In test suite merge IssuingRules with CirculationRules After Bug 18936, in test suite, there is still t/db_dependent/Koha/IssuingRules.t and t/db_dependent/Koha/IssuingRules/ This patch moves IssuingRules.t inside CirculationRules.t and renames dir t/db_dependent/Koha/IssuingRules. And adds DB transation in each first-level subtest. Also renames in : use constant GUESSED_ITEMTYPES_KEY => 'Koha_IssuingRules_last_guess'; Test plan : Run prove t/db_dependent/Koha/CirculationRules.t and prove t/db_dependent/Koha/CirculationRules/* -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Samu Heiskanen <samu.heiskanen@hypernova.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Samu Heiskanen <samu.heiskanen@hypernova.fi> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #128577|0 |1 is obsolete| | --- Comment #2 from Samu Heiskanen <samu.heiskanen@hypernova.fi> --- Created attachment 129045 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=129045&action=edit Bug 29705: In test suite merge IssuingRules with CirculationRules After Bug 18936, in test suite, there is still t/db_dependent/Koha/IssuingRules.t and t/db_dependent/Koha/IssuingRules/ This patch moves IssuingRules.t inside CirculationRules.t and renames dir t/db_dependent/Koha/IssuingRules. And adds DB transation in each first-level subtest. Also renames in : use constant GUESSED_ITEMTYPES_KEY => 'Koha_IssuingRules_last_guess'; Test plan : Run prove t/db_dependent/Koha/CirculationRules.t and prove t/db_dependent/Koha/CirculationRules/* Signed-off-by: Samu Heiskanen <samu.heiskanen@hypernova.fi> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #129045|0 |1 is obsolete| | --- Comment #3 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 129138 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=129138&action=edit Bug 29705: In test suite merge IssuingRules with CirculationRules After Bug 18936, in test suite, there is still t/db_dependent/Koha/IssuingRules.t and t/db_dependent/Koha/IssuingRules/ This patch moves IssuingRules.t inside CirculationRules.t and renames dir t/db_dependent/Koha/IssuingRules. And adds DB transation in each first-level subtest. Also renames in : use constant GUESSED_ITEMTYPES_KEY => 'Koha_IssuingRules_last_guess'; Test plan : Run prove t/db_dependent/Koha/CirculationRules.t and prove t/db_dependent/Koha/CirculationRules/* Signed-off-by: Samu Heiskanen <samu.heiskanen@hypernova.fi> Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Failed QA --- Comment #4 from Fridolin Somers <fridolin.somers@biblibre.com> --- Oups t/db_dependent/Koha/IssuingRules.t fails. We can remove the file. And there is still t/db_dependent/Koha/IssuingRules/guess_article_requestable_itemtypes.t. We should simply rename forder. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 --- Comment #5 from Fridolin Somers <fridolin.somers@biblibre.com> --- (In reply to Fridolin Somers from comment #4)
Oups
t/db_dependent/Koha/IssuingRules.t fails. We can remove the file.
And there is still t/db_dependent/Koha/IssuingRules/guess_article_requestable_itemtypes.t. We should simply rename forder.
I mean t/db_dependent/Circulation/IssuingRules I move maxsuspensiondays.t to parent folder and remove IssuingRules folder -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #129138|0 |1 is obsolete| | --- Comment #6 from Fridolin Somers <fridolin.somers@biblibre.com> --- Created attachment 129464 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=129464&action=edit Bug 29705: In test suite merge IssuingRules with CirculationRules After Bug 18936, in test suite, there is still t/db_dependent/Koha/IssuingRules.t and t/db_dependent/Koha/IssuingRules/ This patch moves IssuingRules.t inside CirculationRules.t and renames dir t/db_dependent/Koha/IssuingRules. And adds DB transation in each first-level subtest. Also renames in : use constant GUESSED_ITEMTYPES_KEY => 'Koha_IssuingRules_last_guess'; Test plan : Run prove t/db_dependent/Koha/CirculationRules.t prove t/db_dependent/Koha/CirculationRules/* prove t/db_dependent/Circulation/maxsuspensiondays.t -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #129464|0 |1 is obsolete| | --- Comment #7 from David Nind <david@davidnind.com> --- Created attachment 134439 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=134439&action=edit Bug 29705: In test suite merge IssuingRules with CirculationRules After Bug 18936, in test suite, there is still t/db_dependent/Koha/IssuingRules.t and t/db_dependent/Koha/IssuingRules/ This patch moves IssuingRules.t inside CirculationRules.t and renames dir t/db_dependent/Koha/IssuingRules. And adds DB transation in each first-level subtest. Also renames in : use constant GUESSED_ITEMTYPES_KEY => 'Koha_IssuingRules_last_guess'; Test plan : Run prove t/db_dependent/Koha/CirculationRules.t prove t/db_dependent/Koha/CirculationRules/* prove t/db_dependent/Circulation/maxsuspensiondays.t Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 --- Comment #8 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I tried testing here, but the QA test tools get stuck again having me end up on qa-current-commit branch with untracekd files in t/db_dependent/Koha/CirculationRules/ :( -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #134439|0 |1 is obsolete| | --- Comment #9 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 134682 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=134682&action=edit Bug 29705: In test suite merge IssuingRules with CirculationRules After Bug 18936, in test suite, there is still t/db_dependent/Koha/IssuingRules.t and t/db_dependent/Koha/IssuingRules/ This patch moves IssuingRules.t inside CirculationRules.t and renames dir t/db_dependent/Koha/IssuingRules. And adds DB transation in each first-level subtest. Also renames in : use constant GUESSED_ITEMTYPES_KEY => 'Koha_IssuingRules_last_guess'; Test plan : Run prove t/db_dependent/Koha/CirculationRules.t prove t/db_dependent/Koha/CirculationRules/* prove t/db_dependent/Circulation/maxsuspensiondays.t Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Katrin Fischer <katrin.fischer@bsz-bw.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)| |22.05.00 released in| | Status|Passed QA |Pushed to master -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29705 --- Comment #10 from Fridolin Somers <fridolin.somers@biblibre.com> --- Pushed to master for 22.05, thanks to everybody involved 🦄 -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org