[Bug 43340] New: Koha's SMTP connection rate can trigger errors
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43340 Bug ID: 43340 Summary: Koha's SMTP connection rate can trigger errors Initiative type: --- Sponsorship --- status: Product: Koha Version: Main Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Notices Assignee: koha-bugs@lists.koha-community.org Reporter: kyle@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: martin.renvoize@openfifth.co.uk Target Milestone: --- When sending email, Koha creates a new SMTP connection for each message. Every single notice does a full connect: EHLO => STARTTLS => auth => send => quit A burst of notices means dozens of connections in seconds from one IP. In practice, this seems to trigger Goggole's Google's per-IP connection rate limiting, which responds with 421-4.7.0 at EHLO. Koha doesn't limit simultaneous connections. There's only ever one connection at a time (the cron is a single sequential process). The problem is connection rate, and Koha has no throttle, delay, or connection-reuse. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43340 Eric Swenson <eric@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |eric@bywatersolutions.com --- Comment #1 from Eric Swenson <eric@bywatersolutions.com> --- Yes, I have seen this be an issue for libraries that are trying to use an external SMTP server. The notices don't try again later, they just fail. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43340 Brendan Lawlor <blawlor@clamsnet.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |blawlor@clamsnet.org -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43340 Kyle M Hall (khall) <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Koha's SMTP connection rate |Koha does not gracefully |can trigger errors |handle SMTP 421 responses -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43340 --- Comment #2 from Kyle M Hall (khall) <kyle@bywatersolutions.com> --- I believe I was mistaken about the most basic issue. After more research I remembered we are using Email::Sender::Transport::SMTP::Persistent ( Bug 33964 ) so unless there is a bug in that lib, it's unlikely to be the problem. Be it that or not, the solution is the same. We need to implement an initial and exponential backoff anytime Koha gets a 421 response ( https://mailtester.com/blog/automate-retry-logic-421-4-7-0-try-again-later/ ). -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org