[Bug 29309] New: 'Pay all fines' should be 'Pay all'
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Bug ID: 29309 Summary: 'Pay all fines' should be 'Pay all' Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Fines and fees Assignee: koha-bugs@lists.koha-community.org Reporter: tomascohen@gmail.com QA Contact: testopia@bugs.koha-community.org It is inconsistent right now. They are not all fines, and that's why we should rename it. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |tomascohen@gmail.com |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |String patch Summary|'Pay all fines' should be |'Pay all fines' should be |'Pay all' |'Pay all charges' -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de, | |martin.renvoize@ptfs-europe | |.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 --- Comment #1 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Created attachment 126789 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=126789&action=edit Bug 29309: Make 'Pay all fines' be 'Pay all charges' It is not just fines, it is also fees, etc. To test: 1. Have a patron with debt 2. Go to the circulation page for the patron => FAIL: There's a button saying 'Pay all fines' 3. Apply this patch and reload page => SUCCESS: The button now says 'Pay all charges' 4. Enjoy the new terminology 5. Sign off :-D Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #126789|0 |1 is obsolete| | --- Comment #2 from David Nind <david@davidnind.com> --- Created attachment 126790 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=126790&action=edit Bug 29309: Make 'Pay all fines' be 'Pay all charges' It is not just fines, it is also fees, etc. To test: 1. Have a patron with debt 2. Go to the circulation page for the patron => FAIL: There's a button saying 'Pay all fines' 3. Apply this patch and reload page => SUCCESS: The button now says 'Pay all charges' 4. Enjoy the new terminology 5. Sign off :-D Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |david@davidnind.com Keywords| |Manual -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 --- Comment #3 from David Nind <david@davidnind.com> --- I love it when terminology inconsistencies are fixed up! The current message "Checkouts are BLOCKED because fine balance is OVER THE LIMIT" needs fixing as well - I will create a separate bug for that. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 --- Comment #4 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to David Nind from comment #3)
I love it when terminology inconsistencies are fixed up!
The current message "Checkouts are BLOCKED because fine balance is OVER THE LIMIT" needs fixing as well - I will create a separate bug for that.
Give me the right wording, and I'll write it as a patch on your behalf, as a follow-up here! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 --- Comment #5 from David Nind <david@davidnind.com> --- (In reply to Tomás Cohen Arazi from comment #4)
Give me the right wording, and I'll write it as a patch on your behalf, as a follow-up here!
Options to change "Checkouts are BLOCKED because fine balance is OVER THE LIMIT": 1. Checkouts are BLOCKED because the amount owed is OVER THE LIMIT 2. Checkouts are BLOCKED because outstanding charges are OVER THE LIMIT 3. Checkouts are BLOCKED because the amount outstanding is OVER THE LIMIT 4. Checkouts are BLOCKED because the patron's balance is OVER THE LIMIT 5. Checkouts are BLOCKED because the balance for fees and charges is OVER THE LIMIT I prefer option 4. Thanks Tomás! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #126790|0 |1 is obsolete| | --- Comment #6 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 126792 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=126792&action=edit Bug 29309: Make 'Pay all fines' be 'Pay all charges' It is not just fines, it is also fees, etc. To test: 1. Have a patron with debt 2. Go to the circulation page for the patron => FAIL: There's a button saying 'Pay all fines' 3. Apply this patch and reload page => SUCCESS: The button now says 'Pay all charges' 4. Enjoy the new terminology 5. Sign off :-D Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 --- Comment #7 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 126793 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=126793&action=edit Bug 29309: (follow-up) Change 'Pay fines' to 'Pay charges' Fixes another occurence of the fines to charges. Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |21.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 --- Comment #8 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Pushed to master for 21.11, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 --- Comment #9 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- (In reply to David Nind from comment #5)
(In reply to Tomás Cohen Arazi from comment #4)
Give me the right wording, and I'll write it as a patch on your behalf, as a follow-up here!
Options to change "Checkouts are BLOCKED because fine balance is OVER THE LIMIT":
1. Checkouts are BLOCKED because the amount owed is OVER THE LIMIT
2. Checkouts are BLOCKED because outstanding charges are OVER THE LIMIT
3. Checkouts are BLOCKED because the amount outstanding is OVER THE LIMIT
4. Checkouts are BLOCKED because the patron's balance is OVER THE LIMIT
5. Checkouts are BLOCKED because the balance for fees and charges is OVER THE LIMIT
I prefer option 4.
Thanks Tomás!
The problem with these, and the original wording too, is that what we block on depends on preferences.. it's not the total outstanding balance, it's a subset of those charges... so we'd need something more generic I think. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 --- Comment #10 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to Martin Renvoize from comment #9)
(In reply to David Nind from comment #5)
(In reply to Tomás Cohen Arazi from comment #4)
Give me the right wording, and I'll write it as a patch on your behalf, as a follow-up here!
Options to change "Checkouts are BLOCKED because fine balance is OVER THE LIMIT":
1. Checkouts are BLOCKED because the amount owed is OVER THE LIMIT
2. Checkouts are BLOCKED because outstanding charges are OVER THE LIMIT
3. Checkouts are BLOCKED because the amount outstanding is OVER THE LIMIT
4. Checkouts are BLOCKED because the patron's balance is OVER THE LIMIT
5. Checkouts are BLOCKED because the balance for fees and charges is OVER THE LIMIT
I prefer option 4.
Thanks Tomás!
The problem with these, and the original wording too, is that what we block on depends on preferences.. it's not the total outstanding balance, it's a subset of those charges... so we'd need something more generic I think.
Maybe we should address each scenario with the right wording? I'm all for that and willing to help. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |Pushed to stable Version(s)|21.11.00 |21.11.00,21.05.05 released in| | CC| |kyle@bywatersolutions.com --- Comment #11 from Kyle M Hall <kyle@bywatersolutions.com> --- Pushed to 21.05.x for 21.05.05 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29309 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |fridolin.somers@biblibre.co | |m --- Comment #12 from Fridolin Somers <fridolin.somers@biblibre.com> --- I prefer not to push to 20.11.x to minimize translation work. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org