[Bug 13290] New: Add better feedback for returns to the checkouts table
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Bug ID: 13290 Summary: Add better feedback for returns to the checkouts table Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Circulation Assignee: koha-bugs@lists.koha-community.org Reporter: kyle@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com, kyle.m.hall@gmail.com The feedback given when returning an item is only to update the "Check in" column. It would be nice if the entire column was highlighted in some way so librarians have an easier time spotting which items were checked in and which ones failed to be checked in. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff Patch complexity|--- |Trivial patch -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 --- Comment #1 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 33663 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=33663&action=edit Bug 13290 - Add better feedback for returns to the checkouts table The feedback given when returning an item is only to update the "Check in" column. It would be nice if the entire column was highlighted in some way so librarians have an easier time spotting which items were checked in and which ones failed to be checked in. Test Plan: 1) Apply this patch 2) Browse to a patron with checkouts 3) Return an item using the checkouts table 4) Note if the return was successful, the row is highlighted in yellow, if the return was not allowed, the row is highlighted in red. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |kyle@bywatersolutions.com |ity.org | Severity|enhancement |minor -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 --- Comment #2 from Owen Leonard <oleonard@myacpl.org> --- I suggest that when an item is successfully checked in the data in the "date due" column be updated too. Perhaps repeat "Returned" there? Or perhaps "Available?" -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |11703 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 --- Comment #3 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to Owen Leonard from comment #2)
I suggest that when an item is successfully checked in the data in the "date due" column be updated too. Perhaps repeat "Returned" there? Or perhaps "Available?"
I like 'returned' since we can't be sure it's available. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |13286 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #33663|0 |1 is obsolete| | --- Comment #4 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 33766 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=33766&action=edit Bug 13290 - Add better feedback for returns to the checkouts table The feedback given when returning an item is only to update the "Check in" column. It would be nice if the entire column was highlighted in some way so librarians have an easier time spotting which items were checked in and which ones failed to be checked in. Test Plan: 1) Apply this patch 2) Browse to a patron with checkouts 3) Return an item using the checkouts table 4) Note if the return was successful, the row is highlighted in yellow, if the return was not allowed, the row is highlighted in red. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 --- Comment #5 from Kyle M Hall <kyle@bywatersolutions.com> --- Updated patch to change the due date to "Returned". Patch now depends on bug 13286 which adds a span to each of the due dates in the checkouts table. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Christopher Brannon <cbrannon@cdalibrary.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA CC| |cbrannon@cdalibrary.org --- Comment #6 from Christopher Brannon <cbrannon@cdalibrary.org> --- While this patch applies the highlighting to all items returned at the same time, it only changes the due date in the due date column on the last item in the list. The due date of all other items returned at the same time are left as due dates. Christopher -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #33766|0 |1 is obsolete| | --- Comment #7 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 34119 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=34119&action=edit Bug 13290 - Add better feedback for returns to the checkouts table The feedback given when returning an item is only to update the "Check in" column. It would be nice if the entire column was highlighted in some way so librarians have an easier time spotting which items were checked in and which ones failed to be checked in. Test Plan: 1) Apply this patch 2) Browse to a patron with checkouts 3) Return an item using the checkouts table 4) Note if the return was successful, the row is highlighted in yellow, if the return was not allowed, the row is highlighted in red. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 --- Comment #8 from Kyle M Hall <kyle@bywatersolutions.com> --- Fixed! (In reply to Christopher Brannon from comment #6)
While this patch applies the highlighting to all items returned at the same time, it only changes the due date in the due date column on the last item in the list. The due date of all other items returned at the same time are left as due dates.
Christopher
-- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 --- Comment #9 from Christopher Brannon <cbrannon@cdalibrary.org> --- Would like to see more specific reason for not being able to return, but that is for another ticket. Works as described. Nice work. Christopher -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Christopher Brannon <cbrannon@cdalibrary.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Christopher Brannon <cbrannon@cdalibrary.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #34119|0 |1 is obsolete| | --- Comment #10 from Christopher Brannon <cbrannon@cdalibrary.org> --- Created attachment 34130 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=34130&action=edit [SIGNED OFF] Bug 13290 - Add better feedback for returns to the checkouts table The feedback given when returning an item is only to update the "Check in" column. It would be nice if the entire column was highlighted in some way so librarians have an easier time spotting which items were checked in and which ones failed to be checked in. Test Plan: 1) Apply this patch 2) Browse to a patron with checkouts 3) Return an item using the checkouts table 4) Note if the return was successful, the row is highlighted in yellow, if the return was not allowed, the row is highlighted in red. Signed-off-by: Christopher Brannon <cbrannon@cdalibary.org> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 --- Comment #11 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 34184 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=34184&action=edit Bug 13290 - Add better feedback for returns to the checkouts table The feedback given when returning an item is only to update the "Check in" column. It would be nice if the entire column was highlighted in some way so librarians have an easier time spotting which items were checked in and which ones failed to be checked in. Test Plan: 1) Apply this patch 2) Browse to a patron with checkouts 3) Return an item using the checkouts table 4) Note if the return was successful, the row is highlighted in yellow, if the return was not allowed, the row is highlighted in red. Signed-off-by: Christopher Brannon <cbrannon@cdalibary.org> Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@biblibre.co | |m --- Comment #12 from Jonathan Druart <jonathan.druart@biblibre.com> --- Maybe a more explicit class name could have been chosen :) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Failed QA --- Comment #13 from Owen Leonard <oleonard@myacpl.org> --- The standard term in the default English templates is "checked in," not "returned." -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #34130|0 |1 is obsolete| | CC| |katrin.fischer@bsz-bw.de -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 --- Comment #14 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- While Owen is right about the convention to use the term "Checked in", we already display "Returned" at the end of the table. I think we should fix this, but separate from this patch. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #34184|0 |1 is obsolete| | --- Comment #15 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 34728 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=34728&action=edit [PASSED QA] Bug 13290 - Add better feedback for returns to the checkouts table The feedback given when returning an item is only to update the "Check in" column. It would be nice if the entire column was highlighted in some way so librarians have an easier time spotting which items were checked in and which ones failed to be checked in. Test Plan: 1) Apply this patch 2) Browse to a patron with checkouts 3) Return an item using the checkouts table 4) Note if the return was successful, the row is highlighted in yellow, if the return was not allowed, the row is highlighted in red. Signed-off-by: Christopher Brannon <cbrannon@cdalibary.org> Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |13495 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master CC| |tomascohen@gmail.com --- Comment #16 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Patch pushed to master. Thanks Kyle! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Chris Cormack <chris@bigballofwax.co.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |Pushed to Stable CC| |chris@bigballofwax.co.nz --- Comment #17 from Chris Cormack <chris@bigballofwax.co.nz> --- Pushed to 3.18.x will be in 3.18.3 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 --- Comment #18 from Chris Cormack <chris@bigballofwax.co.nz> --- Pushed to 3.18.x will be in 3.18.3 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |mtj@kohaaloha.com Keywords| |rel_3_16_candidate --- Comment #19 from Mason James <mtj@kohaaloha.com> --- Pushed to 3.16.x, patch will be in 3.16.7 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13290 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|rel_3_16_candidate | -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org