[Bug 19812] New: Holds count in "Already received" table has confusing and unexpected values
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Bug ID: 19812 Summary: Holds count in "Already received" table has confusing and unexpected values Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: minor Priority: P5 - low Component: Acquisitions Assignee: koha-bugs@lists.koha-community.org Reporter: kyle@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org In acqui/parcel.pl both the "Pending orders" and "Already received" tables show how many holds there are for the given record. However, the count of holds in the "Pending orders" table confuses librarians because it only lists holds for the particular items in the orderline. Due to that, the holds column may show 0 holds even if there are a dozen record level holds for that bib! This is not what librarians seem to expect, instead it seems that the same total holds in the "Pending orders" table would be preferred. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |kyle@bywatersolutions.com |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Small patch Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 --- Comment #1 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 69799 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=69799&action=edit Bug 19812 - Holds count in "Already received" table has confusing and unexpected values In acqui/parcel.pl both the "Pending orders" and "Already received" tables show how many holds there are for the given record. However, the count of holds in the "Pending orders" table confuses librarians because it only lists holds for the particular items in the orderline. Due to that, the holds column may show 0 holds even if there are a dozen record level holds for that bib! This is not what librarians seem to expect, instead it seems that the same total holds in the "Pending orders" table would be preferred. Test Plan: 1) Find an invoice with an item in the "Already received" table 2) Add one or more record level holds to the record 3) Note the holds column does not count those holds 4) Apply this patch 5) Note the holds column now shows total holds and holds for just those ordered items -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |nick@bywatersolutions.com --- Comment #2 from Nick Clemens <nick@bywatersolutions.com> --- *** Bug 19741 has been marked as a duplicate of this bug. *** -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #69799|0 |1 is obsolete| | --- Comment #3 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 69829 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=69829&action=edit Bug 19812 - Holds count in "Already received" table has confusing and unexpected values In acqui/parcel.pl both the "Pending orders" and "Already received" tables show how many holds there are for the given record. However, the count of holds in the "Pending orders" table confuses librarians because it only lists holds for the particular items in the orderline. Due to that, the holds column may show 0 holds even if there are a dozen record level holds for that bib! This is not what librarians seem to expect, instead it seems that the same total holds in the "Pending orders" table would be preferred. Test Plan: 1) Find an invoice with an item in the "Already received" table 2) Add one or more record level holds to the record 3) Note the holds column does not count those holds 4) Apply this patch 5) Note the holds column now shows total holds and holds for just those ordered items Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> Signed-off-by: Nancy Keener <nkeener@washoecounty.us> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Barton Chittenden <barton@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |joy@bywatersolutions.com --- Comment #4 from Barton Chittenden <barton@bywatersolutions.com> --- *** Bug 19846 has been marked as a duplicate of this bug. *** -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |m.de.rooy@rijksmuseum.nl QA Contact|testopia@bugs.koha-communit |m.de.rooy@rijksmuseum.nl |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #69829|0 |1 is obsolete| | --- Comment #5 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 70115 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=70115&action=edit Bug 19812 - Holds count in "Already received" table has confusing and unexpected values In acqui/parcel.pl both the "Pending orders" and "Already received" tables show how many holds there are for the given record. However, the count of holds in the "Pending orders" table confuses librarians because it only lists holds for the particular items in the orderline. Due to that, the holds column may show 0 holds even if there are a dozen record level holds for that bib! This is not what librarians seem to expect, instead it seems that the same total holds in the "Pending orders" table would be preferred. Test Plan: 1) Find an invoice with an item in the "Already received" table 2) Add one or more record level holds to the record 3) Note the holds column does not count those holds 4) Apply this patch 5) Note the holds column now shows total holds and holds for just those ordered items Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> Signed-off-by: Nancy Keener <nkeener@washoecounty.us> Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@bugs.koha-c | |ommunity.org --- Comment #6 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- If there are no holds, should not we display "0" instead of "0 / 0"? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 --- Comment #7 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- "Holds count in "Already received" table has confusing and unexpected values" Does not describe what the patch does. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Failed QA --- Comment #8 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- There is an access to the removed variable "holds" in the template loop_order.holds That means we now see "Can't delete catalog record, see constraints below", but without anything below... -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Passed QA --- Comment #9 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to Jonathan Druart from comment #8)
There is an access to the removed variable "holds" in the template loop_order.holds
That means we now see "Can't delete catalog record, see constraints below", but without anything below...
The code you are referencing is in loop_orders, but this patch only alters loop_received which does not have that message. I'm not sure how this patch could be causing that. If you can give me some line numbers I'd be happy to take another look! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 --- Comment #10 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- (In reply to Kyle M Hall from comment #9)
(In reply to Jonathan Druart from comment #8)
There is an access to the removed variable "holds" in the template loop_order.holds
That means we now see "Can't delete catalog record, see constraints below", but without anything below...
The code you are referencing is in loop_orders, but this patch only alters loop_received which does not have that message. I'm not sure how this patch could be causing that. If you can give me some line numbers I'd be happy to take another look!
Indeed, sounds like I mixed the 2 tables reading the code. Something else: 1. What about comment 6? 2. "1 / 0" reads wrong, but I have no idea how it could be better. 3. line 141 $line{holds} = 0; should be removed, right? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de --- Comment #11 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I've tested it and I think it's still a little confusing. Right now it is: total of holds / holds on on order items Which can lead to the 1 / 0 that Jonathan pointed out. Maybe it would make more sense to switch the values? Or just show the total number of holds = record level + item level on on order items? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |In Discussion -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 --- Comment #12 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to Katrin Fischer from comment #11)
I've tested it and I think it's still a little confusing.
Right now it is: total of holds / holds on on order items
Which can lead to the 1 / 0 that Jonathan pointed out. Maybe it would make more sense to switch the values? Or just show the total number of holds = record level + item level on on order items?
I like the idea of switching the values around. I'll get a followup done asap! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|In Discussion |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 --- Comment #13 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 73606 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=73606&action=edit Bug 19812 [QA Followup] - Swap sides for total and item holds -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 --- Comment #14 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 73607 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=73607&action=edit Bug 19812 [QA Followup] - If 0 holds show '0' not '0 / 0' -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 --- Comment #15 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 73608 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=73608&action=edit Bug 19812 [QA Followup] - Remove unnecessary line -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 --- Comment #16 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Patches will be squashed for readability. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #17 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Pushed to master for 18.05, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |Pushed to Stable --- Comment #18 from Nick Clemens <nick@bywatersolutions.com> --- Pushed to stable for 17.11.06 Awesome work all! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |fridolin.somers@biblibre.co | |m Status|Pushed to Stable |RESOLVED Resolution|--- |FIXED --- Comment #19 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- I prefer not to push to 17.05.x, its minor -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19812 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |23188 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23188 [Bug 23188] Holds Column in Receipt Page sorts oddly -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org