[Bug 15572] New: Authority creation fails when authid is linked to 001 field
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Bug ID: 15572 Summary: Authority creation fails when authid is linked to 001 field Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: critical Priority: P5 - low Component: Cataloging Assignee: gmcharlt@gmail.com Reporter: frederic@tamil.fr QA Contact: testopia@bugs.koha-community.org CC: m.de.rooy@rijksmuseum.nl When adding a new authority, authorities.pl run foreever when authid is linked to 001 field. This is related to bug 6657 which modified the way C4::Biblio::TransformHtmlToMarc operates in order to solve an issue occurring during biblio record cataloging. But this function is also used by authorities cataloging, and the code in this case is irrelevant. Occurs also in 3.20. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Frédéric Demians <frederic@tamil.fr> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@bugs.koha-c | |ommunity.org, | |julian.maurice@biblibre.com | |, katrin.fischer@bsz-bw.de Depends on| |6657 Referenced Bugs: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6657 [Bug 6657] Making 999 visible in framework duplicates 999 entry and affects index -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Frédéric Demians <frederic@tamil.fr> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|gmcharlt@gmail.com |frederic@tamil.fr -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Frédéric Demians <frederic@tamil.fr> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #1 from Frédéric Demians <frederic@tamil.fr> --- Created attachment 46619 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46619&action=edit Bug 6657: Follow-up to fix error on authority creation Bug 6657 modified the way C4::Biblio::TransformHtmlToMarc operates in order to solve an issue occuring during biblio record cataloguing. But this function is also used by authorities cataloguing, and the code in this case is irrelevante. This followup allows to distinguish for which kind of record TransformHtmlToMarc is called: biblio/authority. A bug appears in authority creation without this patch in some circunstances: when authid is linked to 001 field. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #2 from Frédéric Demians <frederic@tamil.fr> --- Created attachment 46620 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46620&action=edit Bug 6657: Add tests for TransformHtmlToMarc Signed-off-by: Frédéric Demians <f.demians@tamil.fr> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #3 from Frédéric Demians <frederic@tamil.fr> --- Created attachment 46621 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46621&action=edit Bug 6657: TransformHtmlToMarc - rewrite the loop This rewrites the while loop into a for loop, so $i still gets incremented when we call next Signed-off-by: Frédéric Demians <f.demians@tamil.fr> Make sense. Add readability. Infinite loop no more possible. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #4 from Frédéric Demians <frederic@tamil.fr> --- Patch-1 has to be sign-off. Patch-2 and 3 are already signed-off. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Bug 15572 depends on bug 6657, which changed state. Bug 6657 Summary: Making 999 visible in framework duplicates 999 entry and affects index http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6657 What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Héctor Eduardo Castro Avalos <hector.hecaxmmx@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Héctor Eduardo Castro Avalos <hector.hecaxmmx@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #46619|0 |1 is obsolete| | --- Comment #5 from Héctor Eduardo Castro Avalos <hector.hecaxmmx@gmail.com> --- Created attachment 46635 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46635&action=edit [SIGNED-OFF]Bug 6657: Follow-up to fix error on authority creation Bug 6657 modified the way C4::Biblio::TransformHtmlToMarc operates in order to solve an issue occuring during biblio record cataloguing. But this function is also used by authorities cataloguing, and the code in this case is irrelevante. This followup allows to distinguish for which kind of record TransformHtmlToMarc is called: biblio/authority. A bug appears in authority creation without this patch in some circunstances: when authid is linked to 001 field. Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com> Tested with a new authority record -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Héctor Eduardo Castro Avalos <hector.hecaxmmx@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #46620|0 |1 is obsolete| | --- Comment #6 from Héctor Eduardo Castro Avalos <hector.hecaxmmx@gmail.com> --- Created attachment 46636 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46636&action=edit Bug 6657: Add tests for TransformHtmlToMarc Signed-off-by: Frédéric Demians <f.demians@tamil.fr> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Héctor Eduardo Castro Avalos <hector.hecaxmmx@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #46621|0 |1 is obsolete| | --- Comment #7 from Héctor Eduardo Castro Avalos <hector.hecaxmmx@gmail.com> --- Created attachment 46637 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46637&action=edit Bug 6657: TransformHtmlToMarc - rewrite the loop This rewrites the while loop into a for loop, so $i still gets incremented when we call next Signed-off-by: Frédéric Demians <f.demians@tamil.fr> Make sense. Add readability. Infinite loop no more possible. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #46635|0 |1 is obsolete| | Attachment #46636|0 |1 is obsolete| | Attachment #46637|0 |1 is obsolete| | --- Comment #8 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 46641 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46641&action=edit Bug 15572: Follow-up to fix error on authority creation Bug 6657 modified the way C4::Biblio::TransformHtmlToMarc operates in order to solve an issue occuring during biblio record cataloguing. But this function is also used by authorities cataloguing, and the code in this case is irrelevante. This followup allows to distinguish for which kind of record TransformHtmlToMarc is called: biblio/authority. A bug appears in authority creation without this patch in some circunstances: when authid is linked to 001 field. Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com> Tested with a new authority record Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #9 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 46642 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46642&action=edit Bug 15572: Add tests for TransformHtmlToMarc Signed-off-by: Frédéric Demians <f.demians@tamil.fr> Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #10 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 46643 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46643&action=edit Bug 15572: TransformHtmlToMarc - rewrite the loop This rewrites the while loop into a for loop, so $i still gets incremented when we call next Signed-off-by: Frédéric Demians <f.demians@tamil.fr> Make sense. Add readability. Infinite loop no more possible. Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #11 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- This subroutine is based on the order of the input in the html... It is really dangerous and should be rewrite. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Brendan Gallagher <brendan@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |brendan@bywatersolutions.co | |m --- Comment #12 from Brendan Gallagher <brendan@bywatersolutions.com> --- So does this still pass QA? Or this is a recommendation that we should rewrite in the future? At this point in the release I am ok - waiting for a rewrite because we still have a couple of months. (In reply to Jonathan Druart from comment #11)
This subroutine is based on the order of the input in the html... It is really dangerous and should be rewrite.
-- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #13 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- (In reply to Brendan Gallagher from comment #12)
So does this still pass QA? Or this is a recommendation that we should rewrite in the future? At this point in the release I am ok - waiting for a rewrite because we still have a couple of months.
Yes, it needs a rewrite. It's how the subroutine has been for years, so no rush :) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #14 from Frédéric Demians <frederic@tamil.fr> --- What is the workflow? This patch is required in 3.22/3.20 branches. Can it be pushed directly without being firstly pushed in master? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #15 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Hi Frederic, I think the fix should go into master and stable releases and then we can rewrite on top of it in master - Jonathan, do you agree? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #16 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- The patches are for master, 3.22.x, 3.20.x and 3.18.x It would be good to have it into the next stable releases. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Jesse Weaver <jweaver@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master CC| |jweaver@bywatersolutions.co | |m --- Comment #17 from Jesse Weaver <jweaver@bywatersolutions.com> --- Pushed to master. Thanks for your work. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Zeno Tajoli <z.tajoli@cineca.it> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |z.tajoli@cineca.it -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #18 from Julian Maurice <julian.maurice@biblibre.com> --- Patches were not pushed in the right order in master, resulting in a code slightly different from what it should be (empty if body instead of a 'next if' statement) I think this should be fixed. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #19 from Julian Maurice <julian.maurice@biblibre.com> --- Patches pushed to 3.22.x, will be in 3.22.2 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #20 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to Julian Maurice from comment #18)
Patches were not pushed in the right order in master, resulting in a code slightly different from what it should be (empty if body instead of a 'next if' statement)
I think this should be fixed.
Perhaps change the status to attract RM attention again? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #21 from Jesse Weaver <jweaver@bywatersolutions.com> --- Patches repushed in correct order. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 --- Comment #22 from Frédéric Demians <frederic@tamil.fr> --- This patch has been pushed to 3.20.x, will be in 3.20.8. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15572 Julian Maurice <julian.maurice@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |Pushed to Stable -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org