[Bug 28372] New: Use variables for 007 controlfield translations in MARC21slim2intranetResults.xsl
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Bug ID: 28372 Summary: Use variables for 007 controlfield translations in MARC21slim2intranetResults.xsl Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Searching Assignee: koha-bugs@lists.koha-community.org Reporter: nick@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org Slight performance improvement over fetching the same field every time -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch Status|NEW |Needs Signoff -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 --- Comment #1 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 121112 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=121112&action=edit Bug 28372: Use variables instead of repeated field lookup This simply replaces repeated lookups of the field with a variable test To test: 1 - Perform a search on the staff client 2 - Note the 'Format' in the record results 3 - Apply patch 4 - Repeat search 5 - Confirm Formats are unchanged -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |nick@bywatersolutions.com |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA --- Comment #2 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Hi Nick, this reads well. Could you please change the OPAC results file as well? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 --- Comment #3 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 140833 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=140833&action=edit Bug 28372: Update OPAC results XSLT to use variables for 007 Same test plan as before, but for OPAC -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |david@davidnind.com --- Comment #4 from David Nind <david@davidnind.com> --- Created attachment 140839 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=140839&action=edit Screenshot - something went wrong with the OPAC display Something is wrong with the OPAC patch - see the screenshot. No details for a record are shown in the OPAC search results. The staff interface display is unchanged. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #140833|0 |1 is obsolete| | --- Comment #5 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 140859 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=140859&action=edit Bug 28372: Update OPAC results XSLT to use variables for 007 Same test plan as before, but for OPAC -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 --- Comment #6 from Nick Clemens <nick@bywatersolutions.com> --- (In reply to David Nind from comment #4)
Created attachment 140839 [details] Screenshot - something went wrong with the OPAC display
Something is wrong with the OPAC patch - see the screenshot.
No details for a record are shown in the OPAC search results.
The staff interface display is unchanged.
Should be fixed, forgot to delete one 'if' -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #121112|0 |1 is obsolete| | --- Comment #7 from David Nind <david@davidnind.com> --- Created attachment 140874 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=140874&action=edit Bug 28372: Use variables instead of repeated field lookup This simply replaces repeated lookups of the field with a variable test To test: 1 - Perform a search on the staff client 2 - Note the 'Format' in the record results 3 - Apply patch 4 - Repeat search 5 - Confirm Formats are unchanged Signed-off-by: David Nind <david@davidnind.com> https://bugs.koha-community.org/show_bug.cgi?id=2837 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #140859|0 |1 is obsolete| | --- Comment #8 from David Nind <david@davidnind.com> --- Created attachment 140875 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=140875&action=edit Bug 28372: Update OPAC results XSLT to use variables for 007 Same test plan as before, but for OPAC Signed-off-by: David Nind <david@davidnind.com> https://bugs.koha-community.org/show_bug.cgi?id=2837 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 --- Comment #9 from David Nind <david@davidnind.com> --- (In reply to Nick Clemens from comment #6)
Should be fixed, forgot to delete one 'if'
Thanks Nick! Now signed off. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #140874|0 |1 is obsolete| | --- Comment #10 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 141484 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=141484&action=edit Bug 28372: Use variables instead of repeated field lookup This simply replaces repeated lookups of the field with a variable test To test: 1 - Perform a search on the staff client 2 - Note the 'Format' in the record results 3 - Apply patch 4 - Repeat search 5 - Confirm Formats are unchanged Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #140875|0 |1 is obsolete| | --- Comment #11 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 141485 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=141485&action=edit Bug 28372: Update OPAC results XSLT to use variables for 007 Same test plan as before, but for OPAC Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com QA Contact|testopia@bugs.koha-communit |martin.renvoize@ptfs-europe |y.org |.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #140839|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA --- Comment #12 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Nice improvement readability wise.. no noticeable change in performance on my part, but I didn't measure it in any meaningful way. I think this is worthwhile for the readability regardless. Passing QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |22.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28372 --- Comment #13 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Pushed to master for 22.11. Nice work everyone, thanks! -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org