[Bug 19794] New: Rename RLIST - Routing list notice template as it' s not related to routing lists
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Bug ID: 19794 Summary: Rename RLIST - Routing list notice template as it's not related to routing lists Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: minor Priority: P5 - low Component: Serials Assignee: koha-bugs@lists.koha-community.org Reporter: katrin.fischer@bsz-bw.de QA Contact: testopia@bugs.koha-community.org CC: colin.campbell@ptfs-europe.com The sample notice RLIST - Routing list has indeed nothing to do with routing lists, but is a sample template for patrons subscribing to get informed by email about newly arriving issues for their favourite serials. There is no connection to the routing list feature at all - so the name is confusing to a lot of people, even if the hint in the subscription form is correct already. I propose to rename the template (help from native speakers welcome): SERIAL_ALERT - New serial issue -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |String patch Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 --- Comment #1 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 72162 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=72162&action=edit Bug 19794: Rename RLIST notice to SERIAL_ALERT to better reflect its purpose The RLIST sample notice is used to send an email to patrons who have subscribed to be notified when a new issue for a subscription arrives. This is a feature that is totally independent and not related to the use of routing lists. In the GUI however, this was misleading so far. - Rename RLIST to SERIAL_ALERT and fixes the sample notices - Fix explanations in the helf files - Fix name of the module in letters from 'serials (routing list)' to 'serials (new issue)' Note: There is no logic to be changed as the notice template to be used is defined for each subscriptions and this is just the sample notice. I've also opted against a database update, to not interfere with existing installations, reports etc. A patch to the manual will be submitted shortly after this passes QA. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |katrin.fischer@bsz-bw.de |ity.org | -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Brendan Gallagher <brendan@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Brendan Gallagher <brendan@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #72162|0 |1 is obsolete| | --- Comment #2 from Brendan Gallagher <brendan@bywatersolutions.com> --- Created attachment 72990 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=72990&action=edit Bug 19794: Rename RLIST notice to SERIAL_ALERT to better reflect its purpose The RLIST sample notice is used to send an email to patrons who have subscribed to be notified when a new issue for a subscription arrives. This is a feature that is totally independent and not related to the use of routing lists. In the GUI however, this was misleading so far. - Rename RLIST to SERIAL_ALERT and fixes the sample notices - Fix explanations in the helf files - Fix name of the module in letters from 'serials (routing list)' to 'serials (new issue)' Note: There is no logic to be changed as the notice template to be used is defined for each subscriptions and this is just the sample notice. I've also opted against a database update, to not interfere with existing installations, reports etc. A patch to the manual will be submitted shortly after this passes QA. Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #72990|0 |1 is obsolete| | --- Comment #3 from Josef Moravec <josef.moravec@gmail.com> --- Created attachment 74242 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=74242&action=edit Bug 19794: Rename RLIST notice to SERIAL_ALERT to better reflect its purpose The RLIST sample notice is used to send an email to patrons who have subscribed to be notified when a new issue for a subscription arrives. This is a feature that is totally independent and not related to the use of routing lists. In the GUI however, this was misleading so far. - Rename RLIST to SERIAL_ALERT and fixes the sample notices - Fix explanations in the helf files - Fix name of the module in letters from 'serials (routing list)' to 'serials (new issue)' Note: There is no logic to be changed as the notice template to be used is defined for each subscriptions and this is just the sample notice. I've also opted against a database update, to not interfere with existing installations, reports etc. A patch to the manual will be submitted shortly after this passes QA. Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com> Signed-off-by: Josef Moravec <josef.moravec@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 --- Comment #4 from Josef Moravec <josef.moravec@gmail.com> --- Created attachment 74243 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=74243&action=edit Bug 19794: (QA follow-up) Change tab to space Test plan: Run qa tools, it should be happy Signed-off-by: Josef Moravec <josef.moravec@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |josef.moravec@gmail.com |y.org | CC| |josef.moravec@gmail.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@bugs.koha-c | |ommunity.org --- Comment #5 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> ---
Note: There is no logic to be changed as the notice template to be used is defined for each subscriptions and this is just the sample notice. I've also opted against a database update, to not interfere with existing installations, reports etc.
Sure? I would update subscription.letter. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 --- Comment #6 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Jonathan Druart from comment #5)
Note: There is no logic to be changed as the notice template to be used is defined for each subscriptions and this is just the sample notice. I've also opted against a database update, to not interfere with existing installations, reports etc.
Sure? I would update subscription.letter.
Hm, can you explain? This only takes effect for new installations as it is now and old ones will be left unchanged. We could, but it won't break anything if we don't, as there is no hardcoded reference to RLIST. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 --- Comment #7 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 74287 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=74287&action=edit Bug 19794: (follow-up) Add atomic update The update will - change the RLIST notice code to SERIAL_ALERT - adapt the description if it has remained unchanged from 'Routing List' to 'New serial issue' - update subscriptions to use the new notice code -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 --- Comment #8 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Added a database update as requested by RM. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 --- Comment #9 from Josef Moravec <josef.moravec@gmail.com> --- Comment on attachment 74287 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=74287 Bug 19794: (follow-up) Add atomic update Review of attachment 74287: --> (https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=19794&attachment=74287) ----------------------------------------------------------------- ::: installer/data/mysql/atomicupdate/bug_19794_update_rlist.sql @@ +1,3 @@
+UPDATE letter SET code = "SERIAL_ALERT" WHERE code = "RLIST"; +UPDATE letter SET name = "New serial issue" WHERE name = "Routing List"; +UPDATE letter SET name = "New serial issue" WHERE name = "Routing List";
This is duplicate. You are missing: UPDATE subscription SET letter = "SERIAL_ALERT" WHERE letter = "RLIST"; -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 --- Comment #10 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Argh, sorry. I tested it all, but silly copy & paste mistake. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #74287|0 |1 is obsolete| | --- Comment #11 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 74289 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=74289&action=edit Bug 19794: (follow-up) Add atomic update The update will - change the RLIST notice code to SERIAL_ALERT - adapt the description if it has remained unchanged from 'Routing List' to 'New serial issue' - update subscriptions to use the new notice code -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #74289|0 |1 is obsolete| | --- Comment #12 from Josef Moravec <josef.moravec@gmail.com> --- Created attachment 74290 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=74290&action=edit Bug 19794: (follow-up) Add atomic update The update will - change the RLIST notice code to SERIAL_ALERT - adapt the description if it has remained unchanged from 'Routing List' to 'New serial issue' - update subscriptions to use the new notice code Signed-off-by: Josef Moravec <josef.moravec@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #13 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Pushed to master for 18.05, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19794 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com Resolution|--- |FIXED Status|Pushed to Master |RESOLVED -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org