[Bug 43443] New: Terminology: Issued should be "Checked out" in bookings
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43443 Bug ID: 43443 Summary: Terminology: Issued should be "Checked out" in bookings Initiative type: --- Sponsorship --- status: Product: Koha Version: 24.11 Hardware: All OS: All Status: NEW Keywords: Academy Severity: minor Priority: P5 - low Component: Templates Assignee: oleonard@myacpl.org Reporter: katrin.fischer@bsz-bw.de QA Contact: testopia@bugs.koha-community.org Target Milestone: --- Found while translating: koha-tmpl/intranet-tmpl/prog/en/modules/bookings/list.tt: issued: () => _("Issued"), koha-tmpl/intranet-tmpl/prog/en/modules/bookings/list.tt: { status: _("Issued"), class: "bg-info" }, Confirmed on Mattermost that "Issued" here means "Checked out", so we should change it to that :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43443 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |String patch CC| |david@davidnind.com Status|NEW |ASSIGNED Assignee|oleonard@myacpl.org |david@davidnind.com Version|24.11 |Main -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43443 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43443 --- Comment #1 from David Nind <david@davidnind.com> --- Created attachment 207259 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=207259&action=edit Bug 43443: Terminology - Change "Issued" to "Checked out" for booking status In the bookings table for a record and a patron's check out and details sections, the status for a booking should be shown as "Checked out" instead of "Issued". Test plan: 1. Enable bookings for the Books (BK) item type: - Administration > Basic parameters > Item types - Edit the Books (BK) item type - Check the Bookable field - Save 2. Make a booking: - For a book item type select "Place booking" (for example, for Programming Perl (262)) - Complete fields for the booking, for example: . Patron: Mary Burton . Pickup at: Centerville . Itemtype: Books . Item: Any item . Booking dates: select the next two days - Click "Submit" - In the Bookings section for the record, the status for the booking is shown as "New" 3. Check out the item for the booking to the patron, for example check out 39999000011418 to Mary Burton: - Confirm the check out: "Yes, check out" 4. For the patron record, check the Bookings tab under the Check out and Details sections: - The status is shown as "Issued" 5. For the record, check the bookings section: - The status is shown as "Issued" 6. Apply the patch 7. Repeat steps 4 and 5: - The status is now shown as "Checked out" 8. Bonus: in the KTD shell run this command: git grep -F '"Issued"' ==> Result: no occurrences found Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43443 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Text to go in the| |This fixes the terminology release notes| |for the status of a | |booking, shown in the | |bookings table for a record | |and a patron's check out | |and details sections. When | |checked out, the status for | |a booking is now shown as | |"Checked out" instead of | |"Issued". --- Comment #2 from David Nind <david@davidnind.com> --- Notes for QA: 1. I only changed the text for the status, not the code used for the status (this is still issued) 2. The Cypress tests for circulation all still pass (I'm not sure if there are selenium tests for bookings): cypress run --spec t/cypress/integration/Circulation 3. I found it a bit odd that "Issued" for the status was used in two separate places (and it is beyond my skills to remove any duplicated code). -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43443 Lisette Scheer <lisette@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #207259|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43443 --- Comment #3 from Lisette Scheer <lisette@bywatersolutions.com> --- Created attachment 207470 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=207470&action=edit Bug 43443: Terminology - Change "Issued" to "Checked out" for booking status In the bookings table for a record and a patron's check out and details sections, the status for a booking should be shown as "Checked out" instead of "Issued". Test plan: 1. Enable bookings for the Books (BK) item type: - Administration > Basic parameters > Item types - Edit the Books (BK) item type - Check the Bookable field - Save 2. Make a booking: - For a book item type select "Place booking" (for example, for Programming Perl (262)) - Complete fields for the booking, for example: . Patron: Mary Burton . Pickup at: Centerville . Itemtype: Books . Item: Any item . Booking dates: select the next two days - Click "Submit" - In the Bookings section for the record, the status for the booking is shown as "New" 3. Check out the item for the booking to the patron, for example check out 39999000011418 to Mary Burton: - Confirm the check out: "Yes, check out" 4. For the patron record, check the Bookings tab under the Check out and Details sections: - The status is shown as "Issued" 5. For the record, check the bookings section: - The status is shown as "Issued" 6. Apply the patch 7. Repeat steps 4 and 5: - The status is now shown as "Checked out" 8. Bonus: in the KTD shell run this command: git grep -F '"Issued"' ==> Result: no occurrences found Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Lisette Scheer <lisette@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43443 Lisette Scheer <lisette@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off --- Comment #4 from Lisette Scheer <lisette@bywatersolutions.com> --- Signed off using a sandbox -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43443 Lisette Scheer <lisette@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |katrin.fischer@bsz-bw.de |y.org | -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org