Greetings,
$filter_module is a string. $object is well, an object.
If my Koha::Filter::MARC::ViewPolicy (to borrow a naming convention from
you) wants to store its parameters for the filter function to access
($self->{options} = $params->{options}; in the initialize() ), this seems
like the better patch to do so. Though, I guess you could do it both ways.
GPML,
Mark Tompsett
Sent: Friday, July 24, 2015 5:27 PM
Subject: Re: [Koha-devel] Koha::RecordProcessor
question
When I first read it I felt something needed re-organization. But
in the end I understood it was almost as we wanted.
What I changed was this:
And if you notice, $param already contains the initialization options on
his 'options' attribute.
Kind regards