> I would rename things to have easier and smaller names to remember and would move things:
>
> - BusinessLogic renamed in Service
> - DBObject renamed in Data
> - DB tables in Schema
>
> Like this, we have one "layer" less (KISS):
> before: BusinessLogic -> DBObject -> DB -> Schema (-> means "use")
> after: Service -> Data -> Schema
>
> Data become the only thing to call Schema DBIx::Class and seems to me more clear (if object needs only one table, ok, we'll have a very simple object and crud sub if object needs more agregation, the crud sub can become - a little bit - more complex).
+1 from me as well.
Regards,
Jared