Hi all, I propose that new Koha Plugin Hooks start with a prefix of "hook_". If you look at https://wiki.koha-community.org/wiki/Koha_Plugin_Hooks or the Kitchen Sink plugin, it's impossible to tell what methods are "hooks" and what are part of the basic plugin core API. Also, if a hook is going to modify a template directly (https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27114 and https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27120), I think we should probably come up with some agreements on how that's best to work, so we don't end up with N different approaches for the same intention. I think that https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26890 raises some interesting issues about how it's not easy to modify Koha's HTML output using plugins. Perhaps we should have a little analysis of some key pages and identify hooks, or do something a bit more complex/comprehensive. (Of course, I already have too many other things I'm working on do a POC for this right now.) David Cook Software Engineer Prosentient Systems 72/330 Wattle St Ultimo, NSW 2007 Australia Office: 02 9212 0899 Online: 02 8005 0595
participants (1)
-
dcook@prosentient.com.au