ALL Programmers & Template designers please note
Hi all, Although officially KOHA runs on Unix and Firefox there is quite a lot out there that uses Windows and Internet Explorer with Koha. Especially with the new ZOOM integration KOHA is now fully Windows compatible as well. However a silly javascript error prevents current frameworks from being used in Internet Explorer. The bug (I consider it a bug in IE) is that any popup window name that contains a space throws a javascript error. So please name the popup windows in window.open scripts with no space. i.e. instead of “Koha Help” pls use “Koha_Help” or a single word. This will help those windows users like us as not to edit all the templates everytime we update. I know that officially we say Firefox but I think it’s a shame to ignore IE just because of one its bugs. Thanks all, Tumer -- No virus found in this outgoing message. Checked by AVG Free Edition. Version: 7.1.405 / Virus Database: 268.11.3/423 - Release Date: 18.08.2006
Tumer Garip a écrit :
Hi all,
Although officially KOHA runs on Unix and Firefox there is quite a lot out there that uses Windows and Internet Explorer with Koha.
Especially with the new ZOOM integration KOHA is now fully Windows compatible as well.
However a silly javascript error prevents current frameworks from being used in Internet Explorer. The bug (I consider it a bug in IE) is that any popup window name that contains a space throws a javascript error. So please name the popup windows in window.open scripts with no space. i.e. instead of “Koha Help” pls use “Koha_Help” or a single word.
This will help those windows users like us as not to edit all the templates everytime we update.
I know that officially we say Firefox but I think it’s a shame to ignore IE just because of one its bugs.
Thanks all,
Hi Tumer. You are right in your bug description (alghough I cannot test), as usual. But I donot agree with the solution you propose. Maybe it can be overcome with using <!--TMPL_VAR Name="tata" ESCAPE=URI--> or ESCAPE=HTML in the template rather than changing script names or call. Did you try such a solution ? I think this may solve the problem. And we could then use it as a temporary solution for javascript window popups... As long as we are not sure to have changed all the script names. -- Henri-Damien LAURENT
Hi Henri, I think there is confusion here. Propably due to the fact that my mail talks abot frameworks instead ot templates. Sorry about that. Here is an example script from addbiblio templates that will throw an error: function Dopop(link,i) { defaultvalue=document.forms['f'].field_value[i].value; newin=window.open(link+"&result="+defaultvalue,"value builder",'width=550,height=550,toolbar=false,scrollbars=yes'); } I am saying that "value builder" should be named as "value_buider" or any other single word Hope its more clear now. Tumer -----Original Message----- From: Henri-Damien LAURENT [mailto:laurenthdl@alinto.com] Sent: Tuesday, August 22, 2006 9:23 AM To: Tumer Garip Cc: koha-devel@nongnu.org Subject: Re: [Koha-devel] ALL Programmers & Template designers please note Tumer Garip a écrit :
Hi all,
Although officially KOHA runs on Unix and Firefox there is quite a lot
out there that uses Windows and Internet Explorer with Koha.
Especially with the new ZOOM integration KOHA is now fully Windows compatible as well.
However a silly javascript error prevents current frameworks from being used in Internet Explorer. The bug (I consider it a bug in IE) is that any popup window name that contains a space throws a javascript error. So please name the popup windows in window.open scripts with no space. i.e. instead of “Koha Help” pls use “Koha_Help”
or a single word.
This will help those windows users like us as not to edit all the templates everytime we update.
I know that officially we say Firefox but I think it’s a shame to ignore IE just because of one its bugs.
Thanks all,
Hi Tumer. You are right in your bug description (alghough I cannot test), as usual. But I donot agree with the solution you propose. Maybe it can be overcome with using <!--TMPL_VAR Name="tata" ESCAPE=URI--> or ESCAPE=HTML in the template rather than changing script names or call. Did you try such a solution ? I think this may solve the problem. And we could then use it as a temporary solution for javascript window popups... As long as we are not sure to have changed all the script names. -- Henri-Damien LAURENT
participants (3)
-
Henri-Damien LAURENT -
Tumer Garip -
Tümer Garip