[Koha-bugs] [Bug 11682] serials.status is too dependent on magic numbers

bugzilla-daemon at bugs.koha-community.org bugzilla-daemon at bugs.koha-community.org
Wed Feb 5 16:51:13 CET 2014


http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11682

--- Comment #7 from Galen Charlton <gmcharlt at gmail.com> ---
(In reply to Jonathan Druart from comment #4)
> (In reply to Galen Charlton from comment #0)
> > [3] Create a new serial_issue_status column to manage the statuses.  It
> > might look like this:
> > 
> > id INTEGER -- status ID
> > name VARCHAR(255) -- label of status
> > missing BOOLEAN -- whether or not the status should be considered to
> > represent an issue that was never received
> 
> I'm not sure it is enough.
> The status value is checked at several places in the code:
> 
>  1/ (planneddate < now() AND serial.status=1) OR serial.STATUS IN (3, 4, 41,
> 42, 43, 44)
> 
>  2/ WHERE ((planneddate < now() AND serial.STATUS =1) OR serial.STATUS = 3)
> 
> and some others.
> 
> The "missing" boolean won't permit to write a SQL query doing the same thing.

Good point.  Additional flags would cover the cases you've listed, e.g.,

is_expected_status
is_late_status
is_claimed_status

However, we could also pin the IDs for those statuses and use named constants
in the code for those, and use an deletable flag in the serial_issue_status to
control whether the user can remove that status.

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are watching all bug changes.


More information about the Koha-bugs mailing list