[Koha-bugs] [Bug 14217] Add a DOM syntax for specifying conditions on indexes

bugzilla-daemon at bugs.koha-community.org bugzilla-daemon at bugs.koha-community.org
Thu Sep 3 13:01:35 CEST 2015


http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14217

--- Comment #11 from Jonathan Druart <jonathan.druart at bugs.koha-community.org> ---
If I am not wrong, the algorithm is:

if conditions exist:
  if the condition is satisfied:
    do a big loop on subfield
else:
  do the same big loop on subfield

You have c/p the "big loop"

I suggest to change with something like

need_to_loop = 1
if conditions exist:
  need_to_loop = 0
  if the condition is satisfied:
    need_to_loop = 1

if need_to_loop:
  do the same big loop on subfield

Just to avoid the code duplication.

-- 
You are receiving this mail because:
You are watching all bug changes.


More information about the Koha-bugs mailing list