[Koha-bugs] [Bug 17855] Updated Koha web installer and new onboarding tool feature to guide users through setting up Koha

bugzilla-daemon at bugs.koha-community.org bugzilla-daemon at bugs.koha-community.org
Wed Jan 11 06:30:21 CET 2017


https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17855

--- Comment #34 from M. Tompsett <mtompset at hotmail.com> ---
Comment on attachment 58793
  --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=58793
Bug 17855 - onboarding.pl script has been created.

Review of attachment 58793:
 --> (https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=17855&attachment=58793)
-----------------------------------------------------------------

::: installer/install.pl
@@ +14,5 @@
> +# # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +# # GNU General Public License for more details.
> +# #
> +# # You should have received a copy of the GNU General Public License
> +# # along with Koha; if not, see <http://www.gnu.org/licenses>.

Not quite right. Just #, not "# #".

::: installer/onboarding.pl
@@ +18,5 @@
> +# # You should have received a copy of the GNU General Public License
> +# # along with Koha; if not, see <http://www.gnu.org/licenses>.
> +
> +use strict;
> +use warnings;

Not needed, since use Modern::Perl is below.

@@ +59,5 @@
> +use Koha::IssuingRules;
> +
> +#Setting variables
> +my $input    = new CGI;
> +my $query    = new CGI;

Is this right? Why two?

@@ +332,5 @@
> +    if($op eq 'add_validate'){
> +         my %newdata;
> +
> +#Store the template form values in the newdata hash      
> +         $newdata{borrowernumber} = $input->param('borrowernumber');       

Try to avoid excess whitespace. Check the wiki for git bz configuration for
some git commands related to whitespace.

@@ +386,5 @@
> +
> +             #Error handling checking if the patron was created successfully
> +             if(!$borrowernumber){
> +                  push @messages, {type=> 'error', code => 'error_on_insert'};
> +             }else{

spacing makes code more readable. Consider running a perl tidy as a separate
patch.

::: summary.pl
@@ +24,5 @@
> +
> +use CGI qw ( -utf8 );
> +use List::MoreUtils qw/ any /;
> +use LWP::Simple;
> +use XML::Simple;

Please check the necessity of all these "use"s.

-- 
You are receiving this mail because:
You are watching all bug changes.


More information about the Koha-bugs mailing list