[Koha-bugs] [Bug 19532] Recalls for Koha

bugzilla-daemon at bugs.koha-community.org bugzilla-daemon at bugs.koha-community.org
Wed Nov 29 18:56:02 CET 2017


https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19532

--- Comment #35 from Tomás Cohen Arazi <tomascohen at gmail.com> ---
Comment on attachment 68572
  --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=68572
Bug 19532: Module files for Recall and OldRecall

>Koha/Recall.pm
>Koha/Recalls.pm
>Koha/Old/Recall.pm
>Koha/Old/Recalls.pm
>and the schema files for Recall and OldRecall.

I agree we should avoid old_*, probably index definitions are relevant for
performance (speed, because they will eat more hard disk space of course).

>+=head2 Class Methods

This are usually labeled 'Internal methods', to distinguish them from public
'Class methods'. Fix the case.

>+=head3 type
>+
>+=cut
>+
>+sub type {
>+    return 'OldRecall';
>+}

This should be called '_type'. Look at Koha/Object.pm:260, a sample place it is
used. If it is not well documented, please file a bug for it!

>+=head2 found
>+
>+  data_type: 'varchar'
>+  is_nullable: 1
>+  size: 1

Please use tinyint(1) for booleans. While it is not a real type (it is an
integer with a mask), it clearly denotes its use. If you plan to expose this
through the api, having it be VARCHAR will make our stack consider it a string.
If you set it a numeric type, then we can add:

__PACKAGE_->add_columns({

  '+found' => { is_boolean => 1 }

});

to the schema file, and thus it is considered a Boolean when rendering on the
API.

-- 
You are receiving this mail because:
You are watching all bug changes.


More information about the Koha-bugs mailing list