[Koha-patches] [PATCH] Bug 4911 Remove duplicated code

Colin Campbell colin.campbell at ptfs-europe.com
Fri Jun 25 11:46:51 CEST 2010


Two duplicated subroutine definitions removed
---
 reports/guided_reports.pl |   12 ------------
 1 files changed, 0 insertions(+), 12 deletions(-)

diff --git a/reports/guided_reports.pl b/reports/guided_reports.pl
index d519423..269f7a8 100755
--- a/reports/guided_reports.pl
+++ b/reports/guided_reports.pl
@@ -601,18 +601,6 @@ sub header_cell_loop {
     return \@headers;
 }
 
-# pass $sth, get back an array of names for the column headers
-sub header_cell_values {
-    my $sth = shift or return ();
-    return @{$sth->{NAME}};
-}
-
-# pass $sth, get back a TMPL_LOOP-able set of names for the column headers
-sub header_cell_loop {
-    my @headers = map { +{ cell => $_ } } header_cell_values (shift);
-    return \@headers;
-}
-
 foreach (1..6) {
     $template->param('build' . $_) and $template->param(buildx => $_) and last;
 }
-- 
1.7.0.1



More information about the Koha-patches mailing list