[Koha-bugs] [Bug 29785] Koha::Object->messages must be renamed

bugzilla-daemon at bugs.koha-community.org bugzilla-daemon at bugs.koha-community.org
Tue Feb 1 13:24:35 CET 2022


https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29785

Marcel de Rooy <m.de.rooy at rijksmuseum.nl> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|Signed Off                  |Failed QA
                 CC|                            |m.de.rooy at rijksmuseum.nl

--- Comment #4 from Marcel de Rooy <m.de.rooy at rijksmuseum.nl> ---
This looks like it still needs attention though:

=head3 messages

    my @messages = @{ $bool->messages };

Returns the I<Koha::Object::Message> objects that were recorded.

=cut

sub messages {
    my ( $self ) = @_;

    $self->{_messages} = []
        unless defined $self->{_messages};

    return $self->{_messages};
}

Kind of strange btw that we add a lot of code there?
Koha::Result::Boolean->new(0)->add_message({ message => $error });

Please provide feedback! Thanks

-- 
You are receiving this mail because:
You are watching all bug changes.


More information about the Koha-bugs mailing list