[Koha-bugs] [Bug 29785] Koha::Object->messages must be renamed

bugzilla-daemon at bugs.koha-community.org bugzilla-daemon at bugs.koha-community.org
Tue Feb 1 14:51:25 CET 2022


https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29785

--- Comment #5 from Jonathan Druart <jonathan.druart+koha at gmail.com> ---
(In reply to Marcel de Rooy from comment #4)
> This looks like it still needs attention though:
> 
> =head3 messages
> 
>     my @messages = @{ $bool->messages };
> 
> Returns the I<Koha::Object::Message> objects that were recorded.
> 
> =cut
> 
> sub messages {
>     my ( $self ) = @_;
> 
>     $self->{_messages} = []
>         unless defined $self->{_messages};
> 
>     return $self->{_messages};
> }

This looks correct to me, Koha::Result::Boolean is not inheriting from
Koha::Object.

> Kind of strange btw that we add a lot of code there?
> Koha::Result::Boolean->new(0)->add_message({ message => $error });

Can you detail what you mean here?

-- 
You are receiving this mail because:
You are watching all bug changes.


More information about the Koha-bugs mailing list