https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32739 --- Comment #7 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to David Cook from comment #6)
(In reply to Tomás Cohen Arazi from comment #5)
After talking with Martin, I decided to submit this patches the way they are written.
I decided to rename 'userid' => 'identifier' to make it generic enough. I'm open to discuss if you *also* want to be able to specify *userid* and *cardnumber* explicitly, but I think this is the way to go and thus my proposal.
Best regards
I'd be happy for "identifier" to be added in addition to "userid", but I think renaming it is a problematic idea, since "userid" is already in use by third-party systems using the production API.
Koha has a bit of a habit of making backwards incompatible changes to its "v1" API...
It's a fair point. In this case we could keep the legacy behavior with no harm. We thought being released a couple months ago made it not such a big deal. About V1 and breaking changes, I don't think there have been many, but truth is we are just reaching a point in which we can call the API stable. -- You are receiving this mail because: You are watching all bug changes.