https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38338 --- Comment #64 from David Cook <dcook@prosentient.com.au> --- (In reply to Olivier Hubert from comment #63)
(In reply to David Cook from comment #62)
Olivier: Do you have any thoughts about where to store the refresh_token when adding the authorization code grant?
Yes. I have updated the structure of the oauth_access_tokens table, and added a field called `type`. So now a stored OAUTH token can be either for the auth process, for SMTP OAUTH or a refresh token.
I went with this approach because it seemed redundant to create another table while we have one named oauth_access_tokens.
Yeah, makes sense. I suppose it would be nice to rename it to "oauth_tokens" but I think it's OK at this point -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.