https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26132 --- Comment #2 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 107735 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=107735&action=edit Bug 26132: Remove raw sql query Making use of Koha::Checkouts make the code much more readable here. It fixes 2 flaws: * $type was not quote escaped * the effective itemtype was not used which could lead to wrong calculation (for instance item-level_itypes is set but the item does not have the itype defined) However there is something to note, we are going to make things a bit less effective as we are now fetching the items to get their effective itemtype (vs a SUM done at DB level) -- You are receiving this mail because: You are watching all bug changes.